PKGBUILD 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # $Id$
  2. # Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
  3. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  4. # Contributor: André Silva <emulatorman@hyperbola.info>
  5. # parabola changes and rationale
  6. # - removed geoclue2 support
  7. pkgname=empathy
  8. pkgver=3.25.90+34+g78f4d4fda
  9. pkgrel=3.nonprism1
  10. pkgdesc="A GNOME instant messaging client using the Telepathy framework, without geoclue2 support"
  11. url="https://wiki.gnome.org/Apps/Empathy"
  12. arch=(x86_64 i686 armv7h)
  13. license=(GPL2)
  14. depends=(clutter-gst clutter-gtk folks gcr iso-codes libcanberra libpulse webkit2gtk
  15. telepathy-farstream telepathy-glib telepathy-logger telepathy-mission-control
  16. geocode-glib cheese libchamplain libgudev)
  17. makedepends=(intltool itstool docbook-xsl python gnome-common git)
  18. optdepends=('telepathy-gabble: XMPP/Jabber support'
  19. 'telepathy-idle: IRC support'
  20. 'telepathy-salut: Link-local XMPP support'
  21. 'telepathy-haze: libpurple support')
  22. _commit=78f4d4fdadd7da67e063c2905649f6a6015ef8f9 # master
  23. source=("git+https://git.gnome.org/browse/empathy#commit=$_commit"
  24. "git+https://git.gnome.org/browse/telepathy-account-widgets"
  25. enchant-2.patch)
  26. sha256sums=('SKIP'
  27. 'SKIP'
  28. 'f177f0dfc242018dd52e312637f513fd08f64aa991b45930cc3ea9a2576f795e')
  29. pkgver() {
  30. cd $pkgname
  31. git describe --tags | sed 's/^EMPATHY_//;s/_/./g;s/-/+/g'
  32. }
  33. prepare() {
  34. cd $pkgname
  35. git submodule init
  36. git config --local submodule.telepathy-account-widgets.url "$srcdir/telepathy-account-widgets"
  37. git submodule update
  38. patch -Np1 -i ../enchant-2.patch
  39. NOCONFIGURE=1 ./autogen.sh
  40. }
  41. build() {
  42. cd $pkgname
  43. export LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
  44. ./configure --prefix=/usr \
  45. --sysconfdir=/etc \
  46. --libexecdir=/usr/lib/empathy \
  47. --disable-static \
  48. --disable-Werror \
  49. --enable-location=no
  50. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  51. make
  52. }
  53. package() {
  54. cd $pkgname
  55. make DESTDIR="$pkgdir" install
  56. }