PKGBUILD 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Maintainer (Arch): Martin Poehlmann <mpdeimos@outlook.com>
  2. # Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
  3. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  4. pkgname=california
  5. pkgver=0.4.0
  6. pkgrel=4.nonprism1
  7. pkgdesc='A new calendar application for GNOME 3. It is currently under heavy development, without Google Calendar support'
  8. arch=('i686' 'x86_64' 'armv7h')
  9. url="https://wiki.gnome.org/Apps/California"
  10. license=('LGPL2.1')
  11. depends=('evolution-data-server' 'libgee' 'xdg-utils' "libical>=3" "libical<4")
  12. makedepends=('vala' 'intltool' 'gnome-common' 'yelp-tools' 'gobject-introspection' 'patch')
  13. install="${pkgname}.install"
  14. source=('https://download.gnome.org/sources/california/0.4/california-0.4.0.tar.xz'
  15. 'https://src.fedoraproject.org/cgit/rpms/california.git/plain/0002-Build-with-evolution-data-server-3.13.90.patch'
  16. 'https://src.fedoraproject.org/cgit/rpms/california.git/plain/california-0.4.0-libical-3.0.patch'
  17. 'nonprism.patch')
  18. sha256sums=('b25f356363a9f8f8f93c7ab78af02de39f9c3b71964663129ac9904de9147eb6'
  19. 'f512f50470954ec4018c99c49c37fa7e23074653a2e090ff13e32631ec10293d'
  20. 'c6924c868d2b44639463ce7e426c5917377ec7d0d6aa0fd38f7a018a9563be33'
  21. '31bb9d156017c308d5ab18e515b1310db8f890a1defee8d0ee6a5ac3cb65a76e')
  22. prepare() {
  23. cd "${srcdir}/${pkgname}-${pkgver}"
  24. patch -p1 < ../0002-Build-with-evolution-data-server-3.13.90.patch
  25. patch -p1 < ../california-0.4.0-libical-3.0.patch
  26. # remove Google Calendar support
  27. patch -Np1 -i "$srcdir/nonprism.patch"
  28. rm -rv src/activator/google
  29. cd po
  30. for file in *.po; do
  31. intltool-update ${file%.*}
  32. msgattrib --no-obsolete -o $file $file
  33. done
  34. cd "${srcdir}/${pkgname}-${pkgver}"
  35. ./configure \
  36. --prefix=/usr \
  37. --disable-fatal
  38. sed -i 's#californiadocdir = ${prefix}#californiadocdir = ${datadir}#g' Makefile
  39. sed -i 's/static const/const/' src/host/host-main-window.vala
  40. sed -i 's/static const/const/' src/application/california-application.vala
  41. }
  42. build() {
  43. cd "${srcdir}/${pkgname}-${pkgver}"
  44. make
  45. }
  46. package() {
  47. local _icu_ver
  48. _icu_ver=$(pacman -S --print-format='%v' icu)
  49. depends+=("icu>=${_icu_ver}" "icu<$((${_icu_ver%%.*} + 1))")
  50. cd "${srcdir}/${pkgname}-${pkgver}"
  51. make install DESTDIR="$pkgdir"
  52. install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
  53. }