PKGBUILD 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Maintainer: Parabola automatic package builder <autobuilder@parabola.nu>
  2. # NOTE: this PKGBUILD does not need to be edited manually
  3. # the package is normally built automatically by autobuilder
  4. # to generate a new keyring, push a new commit to hackers.git
  5. # eg: $ git commit --allow-empty --message=rebuild
  6. # $ git push parabola master
  7. # autobuilder will modify this PKGBUILD, build and publish the package,
  8. # and commit the modified PKGBUILD to abslibre
  9. pkgname=parabola-keyring
  10. pkgver=20210723
  11. _gitver=7b3eac20134e14161a810add6f6647f2a06c8ee0
  12. pkgrel=1
  13. pkgdesc='Parabola GNU/Linux-libre PGP keyring'
  14. arch=('any')
  15. url='https://git.parabola.nu/hackers.git/'
  16. license=('GPL')
  17. makedepends=(parabola-hackers git)
  18. install=$pkgname.install
  19. source=("hackers-${_gitver}::git://git.parabola.nu/hackers.git#commit=${_gitver}")
  20. sha512sums=('SKIP')
  21. prepare() {
  22. cd "$srcdir"
  23. mv {,.}hackers-$_gitver
  24. mkdir .cachedir
  25. export PARABOLA_HACKERS_YAMLDIR="$PWD/.hackers-$_gitver/users"
  26. /usr/lib/parabola-hackers/pacman-make-keyring \
  27. V="$pkgver" \
  28. keyserver='hkp://pgp.cyberbits.eu:11371' \
  29. cachedir="$PWD/.cachedir"
  30. }
  31. package() {
  32. cd "$srcdir"
  33. bsdtar xf "$pkgname-$pkgver.tar.gz"
  34. cd "$srcdir/$pkgname-$pkgver"
  35. make PREFIX=/usr DESTDIR="${pkgdir}" install
  36. }