PKGBUILD 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980
  1. # $Id$
  2. # Maintainer (Arch): Sven-Hendrik Haase <sh@lutzhaase.com>
  3. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  4. # Contributor: Márcio Silva <coadde@hyperbola.info>
  5. # parabola changes and rationale:
  6. # - not building ogre-docs
  7. # - removed nonfree samples and tests
  8. # - removed nonfree files and references
  9. pkgbase=ogre
  10. pkgname=('ogre')
  11. pkgver=1.10.11
  12. pkgrel=3.parabola1
  13. pkgdesc='Scene-oriented, flexible 3D engine written in C++, without nonfree software support and files'
  14. arch=('x86_64' 'i686' 'armv7h')
  15. url='http://www.ogre3d.org'
  16. license=('custom:MIT')
  17. depends=('boost-libs' 'freeimage' 'freetype2' 'libxaw' 'libxrandr'
  18. 'zziplib' 'sdl2' 'glu' 'tinyxml')
  19. makedepends=('boost' 'cmake' 'doxygen' 'graphviz' 'ttf-dejavu' 'mesa' 'mercurial' 'python' 'swig' 'systemd')
  20. install=ogre.install
  21. source=("https://github.com/OGRECave/ogre/archive/v${pkgver}.tar.gz"
  22. libre.patch)
  23. sha512sums=('2dfedd6f0a0de1a8c687c001439138b233200ca11e5c9940debf43d8a0380ca6472e0b5f4d599f0e22ca2049d0a5d34066ef41b6bc4912130694fa5d851fc900'
  24. '81e3997c5bad64d8bae511222d8ab3766699c0923e9303640925525908ee2c19dfb37549cc02bc3e172ea248c0c01c0a58bdcc20d545980bf93b15e02ceb514c')
  25. prepare() {
  26. cd ogre-${pkgver}
  27. # remove nonfree files
  28. rm -v RenderSystems/GL/include/GL/gl.h
  29. rm -rv Samples/Media/materials/textures/nvidia
  30. rm -v Samples/Media/packs/chiropteraDM.{pk3,txt}
  31. # remove nonfree references
  32. rm -v CMake/Templates/quakemap.cfg.in
  33. patch -Np1 -i $srcdir/libre.patch
  34. }
  35. build() {
  36. cd ogre-${pkgver}
  37. [[ -d build ]] && rm -rf build
  38. mkdir build && cd build
  39. cmake .. \
  40. -DCMAKE_INSTALL_PREFIX=/usr \
  41. -DOGRE_INSTALL_SAMPLES=FALSE\
  42. -DOGRE_INSTALL_DOCS=FALSE\
  43. -DOGRE_INSTALL_SAMPLES_SOURCE=FALSE\
  44. -DOGRE_BUILD_DEPENDENCIES=FALSE \
  45. -DOGRE_BUILD_COMPONENT_PYTHON=TRUE \
  46. -DCMAKE_BUILD_TYPE=Release \
  47. -DOGRE_BUILD_RENDERSYSTEM_GL=FALSE\
  48. -DOGRE_BUILD_RENDERSYSTEM_GLES=FALSE\
  49. -DOGRE_BUILD_RENDERSYSTEM_GLES2=FALSE\
  50. -DOGRE_BUILD_SAMPLES=FALSE\
  51. -DOGRE_BUILD_TESTS=FALSE
  52. make
  53. }
  54. package_ogre() {
  55. optdepends=('cppunit: unit testing'
  56. 'intel-tbb: better threading support'
  57. 'poco: portability'
  58. 'python: python bindings'
  59. 'boost: for developing using ogre'
  60. 'ogre-docs: documentation')
  61. cd ogre-${pkgver}/build
  62. make DESTDIR=${pkgdir} install
  63. install -Dm644 ../LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
  64. }
  65. # vim:set ts=2 sw=2 et: