PKGBUILD 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
  2. # Contributor: Andrea Scarpino <andrea@archlinux.org>
  3. # Contributor: Giovanni Scafora <giovanni@archlinux.org>
  4. # parabola changes and rationale:
  5. # - arch package links to qt5-webengine
  6. # - no changes necessary - simply rebuild without qt5-webengine in the environment
  7. pkgname=kdevelop
  8. pkgver=5.6.2
  9. _clangver=12.0.1
  10. [[ "${CARCH}" == 'i686' ]] && _clangver=12.0.0
  11. pkgrel=5
  12. pkgrel+=.parabola1
  13. pkgdesc='C++ IDE using KDE technologies'
  14. pkgdesc+=', without qt5-webengine dependency'
  15. arch=(x86_64)
  16. arch+=(armv7h i686)
  17. url='http://www.kdevelop.org/'
  18. license=(GPL)
  19. depends=(clang=$_clangver libksysguard kitemmodels knotifyconfig ktexteditor grantlee libkomparediff2
  20. kcmutils threadweaver knewstuff)
  21. makedepends=(extra-cmake-modules kdoctools kdevelop-pg-qt llvm qt5-tools plasma-framework krunner okteta boost purpose subversion astyle)
  22. optdepends=('konsole: embedded terminal'
  23. 'git: Git support' 'subversion: SVN support'
  24. 'gdb: GNU debugger support' 'lldb: LLDB debugger support'
  25. 'qt5-doc: Qt documentation integration'
  26. 'cmake: cmake integration'
  27. 'meson: meson integration'
  28. 'qt5-tools: qthelp plugin'
  29. 'okteta: GNU debugger support'
  30. 'plasma-framework: for the plasma addons'
  31. 'purpose: patch review plugin'
  32. 'astyle: astyle plugin'
  33. 'cppcheck: code analyzer' 'heaptrack: memory profiler'
  34. 'clazy: clazy analyzer plugin')
  35. conflicts=(kdevelop-qmljs kdevplatform)
  36. replaces=(kdevelop-qmljs kdevplatform kdevelop-clang-tidy)
  37. source=("https://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
  38. sha256sums=('0f86bc3fe53f761c1e3e3f7544577a0c41433be8bff310cf2e729f76f4363bf6'
  39. 'SKIP')
  40. validpgpkeys=('329FD02C5AA48FCC77A4BBF0AC44AC6DB29779E6' # Sven Brauch <mail@svenbrauch.de>
  41. '364EFA5F639572907D392999C64CF56B13CACE5D' # Kevin Funk <kfunk@kde.org>
  42. 'E191FD5BE6F46870F09E82B2024E7FB43D015474' # Friedrich W. H. Kossebau <kossebau@kde.org>
  43. '0A48BC961075B4BA8523E3790A345FB086E797D9' # https://share.kde.org/s/8dKaJTw8pR8iiwJ
  44. 'C51B45A532F17FA401D099A0A0C6B72C4F1C5E7C') # Milian Wolff <mail@milianw.de>
  45. build() {
  46. cmake -B build -S $pkgname-$pkgver \
  47. -Wno-dev \
  48. -DBUILD_TESTING=OFF
  49. cmake --build build
  50. }
  51. package() {
  52. DESTDIR="$pkgdir" cmake --install build
  53. }