123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824 |
- # Maintainer (Arch): Christian Hesse <mail@eworm.de>
- # Maintainer (Arch): Ronald van Haren <ronald.archlinux.org>
- # Contributor (Arch): Tobias Powalowski <tpowa@archlinux.org>
- # Contributor (Arch): Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
- # Maintainer (Hyperbola): André Silva <emulatorman@hyperbola.info>
- # Maintainer (Hyperbola): Márcio Silva <coadde@hyperbola.info>
- # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
- ## '1' to enable Xen support, '0' to disable
- _XEN='0'
- ## '1' to enable IA32-EFI build in Arch x86_64, '0' to disable
- _IA32_EFI_IN_ARCH_X64='1'
- ## '1' to enable IA32-XEN build in Arch x86_64, "0" to disable
- _IA32_XEN_IN_ARCH_X64='1'
- ## '1' to enable EMU build (x86_64 and i686 only), "0" to disable
- _GRUB_EMU_BUILD='0'
- [[ "${CARCH}" = 'armv7h' ]] && _EFI_ARCH='arm'
- [[ "${CARCH}" = 'x86_64' ]] && _EFI_ARCH='x86_64'
- [[ "${CARCH}" = 'i686' ]] && _EFI_ARCH='i386'
- [[ "${CARCH}" = 'x86_64' ]] && _XEN_ARCH='x86_64'
- [[ "${CARCH}" = 'i686' ]] && _XEN_ARCH='i386'
- [[ "${CARCH}" = 'armv7h' ]] && _EMU_ARCH='arm'
- [[ "${CARCH}" = 'x86_64' ]] && _EMU_ARCH='x86_64'
- [[ "${CARCH}" = 'i686' ]] && _EMU_ARCH='i386'
- pkgbase='grub'
- pkgname=('grub')
- [[ $CARCH = armv7h ]] && pkgname+=('grub-am335x_bone' 'grub-udoo' 'grub-omap3_beagle'
- 'grub-omap3_beagle_xm' 'grub-omap3_beagle_xm_ab')
- pkgdesc='GNU GRand Unified Bootloader (2), (Parabola rebranded)'
- epoch=2
- _tag='53c5000739db114c229fe69ec3d4b76b92441098' # git rev-parse grub-${_pkgver}
- _gnulib_commit='be584c56eb1311606e5ea1a36363b97bddb6eed3'
- _unifont_ver='13.0.06'
- _pkgver=2.06
- pkgver=${_pkgver/-/}
- pkgrel=1
- pkgrel+=.parabola1
- url='https://www.gnu.org/software/grub/'
- arch=('x86_64')
- arch+=('i686' 'armv7h')
- license=('GPL3')
- backup=('etc/default/grub'
- 'etc/grub.d/40_custom')
- install="${pkgname}.install"
- options=('!makeflags')
- makedepends=('git' 'rsync' 'xz' 'freetype2' 'ttf-dejavu' 'python' 'autogen'
- 'texinfo' 'help2man' 'gettext' 'device-mapper' 'fuse')
- depends=('sh' 'xz' 'gettext' 'device-mapper')
- optdepends=('freetype2: For grub-mkfont usage'
- 'fuse: For grub-mount usage')
- if [[ "${CARCH}" = 'x86_64' ]] && [[ "${_XEN}" = '1' ]]; then
- makedepends+=('xen')
- fi
- if [[ "${_GRUB_EMU_BUILD}" = "1" ]]; then
- makedepends+=('libusbx' 'sdl')
- fi
- if [[ "${CARCH}" = 'x86_64' ]] || [[ "${CARCH}" = 'i686' ]]; then
- provides=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}")
- conflicts=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}" 'grub-legacy' 'grub-parabola')
- replaces=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}" 'grub-parabola')
- elif [[ "${CARCH}" = 'armv7h' ]]; then
- provides=('grub-common' 'grub-emu' "grub-efi-${_EFI_ARCH}")
- conflicts=('grub-common' 'grub-emu' "grub-efi-${_EFI_ARCH}")
- replaces=('grub-common' 'grub-emu' "grub-efi-${_EFI_ARCH}")
- fi
- validpgpkeys=('E53D497F3FA42AD8C9B4D1E835A93B74E82E4209' # Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
- 'BE5C23209ACDDACEB20DB0A28C8189F1988C2166' # Daniel Kiper <dkiper@net-space.pl>
- '95D2E9AB8740D8046387FD151A09227B1F435A33') #Paul Hardy
- source=("git+https://git.savannah.gnu.org/git/grub.git#tag=${_tag}?signed"
- "git+https://git.savannah.gnu.org/git/gnulib.git#commit=${_gnulib_commit}"
- "https://ftp.gnu.org/gnu/unifont/unifont-${_unifont_ver}/unifont-${_unifont_ver}.bdf.gz"{,.sig}
- '0003-10_linux-20_linux_xen-detect-parabola-initramfs.patch'
- '0001-00_header-add-GRUB_COLOR_-variables.patch'
- 'grub.default'
- '0003-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch'
- '0003-10_linux-20_linux_xen-detect-omap3_beagle-devicetree-file.patch'
- '0003-10_linux-20_linux_xen-detect-omap3_beagle_xm-devicetree-file.patch'
- '0003-10_linux-20_linux_xen-detect-omap3_beagle_xm_ab-devicetree-file.patch'
- '0003-10_linux-20_linux_xen-detect-udoo-devicetree-file.patch'
- '0003-10_linux-20_linux_xen-rebrand-free-distros.patch')
- sha256sums=('SKIP'
- 'SKIP'
- 'b7668a5d498972dc4981250c49f83601babce797be19b4fdd0f2f1c6cfbd0fc5'
- 'SKIP'
- 'b32a28cb5b97b0bb139c0ee2199b81a2aba124c2ead9b01cfd4485fd2551257f'
- '5dee6628c48eef79812bb9e86ee772068d85e7fcebbd2b2b8d1e19d24eda9dab'
- 'ed6cf7d8efc391b9331322e4502f7469473a8ed05599c36e2b18f167b3cb7879'
- '0f2e9abaf872e1e18dfe0cd1da42bdc4f49d3956f97a01c39b82c0e3016c1a32'
- 'c0d84384db273d9fd6ea2aab2a9d8ba36402daf8daf591dcba329cfa02253c87'
- 'ef105dcc067c673e543d4d5384aa7bf6b93e9eca96fec4323ab69a91ec079f56'
- 'f5fb1673536d56a88b3d1aaec75501e4d0acca081ac658d1059ec276f9e062c6'
- 'd8911a513166d2db337b9449542e0ad0e91b114f92dc4b876d88d77d23829a1d'
- '7374137d183957ec8834ce749163c9fa98ff8ee61bbb74b0b38e29daf93857a4')
- _backports=(
- )
- _configure_options=(
- FREETYPE="pkg-config freetype2"
- --enable-mm-debug
- --enable-nls
- --enable-device-mapper
- --enable-cache-stats
- --enable-grub-mkfont
- --enable-grub-mount
- --prefix="/usr"
- --bindir="/usr/bin"
- --sbindir="/usr/bin"
- --mandir="/usr/share/man"
- --infodir="/usr/share/info"
- --datarootdir="/usr/share"
- --sysconfdir="/etc"
- --program-prefix=""
- --with-bootdir="/boot"
- --with-grubdir="grub"
- --disable-silent-rules
- --disable-werror
- )
- prepare() {
- cd "${srcdir}/grub/"
- echo "Apply backports..."
- local _c
- for _c in "${_backports[@]}"; do
- git log --oneline -1 "${_c}"
- git cherry-pick -n "${_c}"
- done
- echo "Patch to enable GRUB_COLOR_* variables in grub-mkconfig..."
- ## Based on http://lists.gnu.org/archive/html/grub-devel/2012-02/msg00021.html
- patch -Np1 -i "${srcdir}/0001-00_header-add-GRUB_COLOR_-variables.patch"
- echo "Patch to detect of Parabola GNU/Linux-libre initramfs images by grub-mkconfig..."
- patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-parabola-initramfs.patch"
- echo "Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme..."
- sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "configure.ac"
- echo "Rebranding for some free distros..."
- patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-rebrand-free-distros.patch"
- echo "Fix mkinitcpio 'rw' FS#36275..."
- sed 's| ro | rw |g' -i "util/grub.d/10_linux.in"
- echo "Pull in latest language files..."
- ./linguas.sh
- echo "Avoid problem with unifont during compile of grub..."
- # http://savannah.gnu.org/bugs/?40330 and https://bugs.archlinux.org/task/37847
- gzip -cd "${srcdir}/unifont-${_unifont_ver}.bdf.gz" > "unifont.bdf"
- }
- _build_grub-efi() {
- echo "Copy the source for building the ${_EFI_ARCH} EFI part..."
- cp -r "${srcdir}/grub/" "${srcdir}/grub-efi-${_EFI_ARCH}/"
- cd "${srcdir}/grub-efi-${_EFI_ARCH}/"
- echo "Unset all compiler FLAGS for ${_EFI_ARCH} EFI build..."
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
- echo "Run bootstrap for ${_EFI_ARCH} EFI build..."
- ./bootstrap \
- --gnulib-srcdir="${srcdir}/gnulib/" \
- --no-git
- echo "Run ./configure for ${_EFI_ARCH} EFI build..."
- ./configure \
- --with-platform="efi" \
- --target="${_EFI_ARCH}" \
- --disable-efiemu \
- --enable-boot-time \
- "${_configure_options[@]}"
- echo "Run make for ${_EFI_ARCH} EFI build..."
- make
- }
- _build_grub-xen() {
- echo "Copy the source for building the ${_XEN_ARCH} XEN part..."
- cp -r "${srcdir}/grub/" "${srcdir}/grub-xen-${_XEN_ARCH}/"
- cd "${srcdir}/grub-xen-${_XEN_ARCH}/"
- echo "Unset all compiler FLAGS for ${_XEN_ARCH} XEN build..."
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
- echo "Run bootstrap for ${_XEN_ARCH} XEN build..."
- ./bootstrap \
- --gnulib-srcdir="${srcdir}/gnulib/" \
- --no-git
- echo "Run ./configure for ${_XEN_ARCH} XEN build..."
- ./configure \
- --with-platform='xen' \
- --target="${_XEN_ARCH}" \
- --disable-efiemu \
- --enable-boot-time \
- "${_configure_options[@]}"
- echo "Run make for ${_XEN_ARCH} XEN build..."
- make
- }
- _build_grub-bios() {
- echo 'Set ARCH dependent variables for BIOS build...'
- if [[ "${CARCH}" = 'x86_64' ]]; then
- _EFIEMU='--enable-efiemu'
- else
- _EFIEMU='--disable-efiemu'
- fi
- echo 'Copy the source for building the BIOS part...'
- cp -r "${srcdir}/grub/" "${srcdir}/grub-bios/"
- cd "${srcdir}/grub-bios/"
- echo 'Unset all compiler FLAGS for BIOS build...'
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
- echo 'Run bootstrap for BIOS build...'
- ./bootstrap \
- --gnulib-srcdir="${srcdir}/gnulib/" \
- --no-git
- echo 'Run ./configure for BIOS build...'
- ./configure \
- --with-platform='pc' \
- --target='i386' \
- "${_EFIEMU}" \
- --enable-boot-time \
- "${_configure_options[@]}"
- echo 'Run make for BIOS build...'
- make
- }
- _build_grub-qemu() {
- echo 'Copy the source for building the QEMU part...'
- cp -r "${srcdir}/grub/" "${srcdir}/grub-qemu/"
- cd "${srcdir}/grub-qemu/"
- echo 'Unset all compiler FLAGS for QEMU build...'
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
- echo 'Run bootstrap for QEMU build...'
- ./bootstrap \
- --gnulib-srcdir="${srcdir}/gnulib/" \
- --no-git
- echo 'Run ./configure for QEMU build...'
- ./configure \
- BUILD_FREETYPE="pkg-config freetype2" \
- --with-platform='qemu' \
- --target='i386' \
- --disable-efiemu \
- --enable-boot-time \
- "${_configure_options[@]}"
- echo 'Run make for QEMU build...'
- make
- }
- _build_grub-ieee1275() {
- echo 'Copy the source for building the IEEE1275 (OpenFirmware) part...'
- cp -r "${srcdir}/grub/" "${srcdir}/grub-ieee1275/"
- cd "${srcdir}/grub-ieee1275/"
- echo 'Unset all compiler FLAGS for IEEE1275 (OpenFirmware) build...'
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
- echo 'Run bootstrap for IEEE1275 (OpenFirmware) build...'
- ./bootstrap \
- --gnulib-srcdir="${srcdir}/gnulib/" \
- --no-git
- echo 'Run ./configure for IEEE1275 (OpenFirmware) build...'
- ./configure \
- --with-platform='ieee1275' \
- --target='i386' \
- --disable-efiemu \
- --enable-boot-time \
- "${_configure_options[@]}"
- echo 'Run make for IEEE1275 (OpenFirmware) build...'
- make
- }
- _build_grub-libreboot() {
- echo 'Copy the source for building the Libreboot part...'
- cp -r "${srcdir}/grub/" "${srcdir}/grub-libreboot/"
- cd "${srcdir}/grub-libreboot/"
- echo 'Unset all compiler FLAGS for Libreboot build...'
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
- echo 'Run bootstrap for Libreboot build...'
- ./bootstrap \
- --gnulib-srcdir="${srcdir}/gnulib/" \
- --no-git
- echo 'Run ./configure for Libreboot build...'
- ./configure \
- BUILD_FREETYPE="pkg-config freetype2" \
- --with-platform='coreboot' \
- --target='i386' \
- --disable-efiemu \
- --enable-boot-time \
- "${_configure_options[@]}"
- echo 'Run make for Libreboot build...'
- make
- }
- _build_grub-multiboot() {
- echo 'Copy the source for building the Multiboot part...'
- cp -r "${srcdir}/grub/" "${srcdir}/grub-multiboot/"
- cd "${srcdir}/grub-multiboot/"
- echo 'Unset all compiler FLAGS for Multiboot build...'
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
- echo 'Run bootstrap for Multiboot build...'
- ./bootstrap \
- --gnulib-srcdir="${srcdir}/gnulib/" \
- --no-git
- echo 'Run ./configure for Multiboot build...'
- ./configure \
- --with-platform='multiboot' \
- --target='i386' \
- --disable-efiemu \
- --enable-boot-time \
- "${_configure_options[@]}"
- echo 'Run make for Multiboot build...'
- make
- }
- _build_grub-emu() {
- echo 'Copy the source for building the emu part...'
- cp -r "${srcdir}/grub/" "${srcdir}/grub-emu/"
- cd "${srcdir}/grub-emu/"
- echo 'Unset all compiler FLAGS for emu build...'
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
- echo 'Run bootstrap for emu build...'
- ./bootstrap \
- --gnulib-srcdir="${srcdir}/gnulib/" \
- --no-git
- echo 'Run ./configure for emu build...'
- ./configure \
- --with-platform='emu' \
- --target="${_EMU_ARCH}" \
- --enable-grub-emu-usb=no \
- --enable-grub-emu-sdl=no \
- --disable-grub-emu-pci \
- "${_configure_options[@]}"
- echo 'Run make for emu build...'
- make
- }
- _build_grub-uboot() {
- echo "Copy the source for building the U-Boot part..."
- cp -r "${srcdir}/grub/" "${srcdir}/grub-uboot/"
- cd "${srcdir}/grub-uboot/"
- echo 'Unset all compiler FLAGS for U-Boot build...'
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
- #sed -i '\|grub_arm_disable_caches_mmu|,+4 d
- # ' grub-core/loader/arm/linux.c
- echo 'Run bootstrap for U-Boot build...'
- ./bootstrap \
- --gnulib-srcdir="${srcdir}/gnulib/" \
- --no-git
- echo 'Run ./configure for U-Boot build...'
- ./configure \
- --with-platform='uboot' \
- --target='arm' \
- --disable-efiemu \
- --enable-boot-time \
- "${_configure_options[@]}"
- echo 'Run make for U-Boot build...'
- make
- }
- build() {
- cd "${srcdir}/grub/"
- if [[ "${CARCH}" = 'x86_64' ]] || [[ "${CARCH}" = 'i686' ]] || [[ "${CARCH}" = 'armv7h' ]]; then
- echo "Build grub ${_EFI_ARCH} EFI stuff..."
- _build_grub-efi
- if [[ "${CARCH}" = 'x86_64' ]] && [[ "${_IA32_EFI_IN_ARCH_X64}" = '1' ]]; then
- echo 'Build grub i386 EFI stuff...'
- _EFI_ARCH='i386' _build_grub-efi
- fi
- fi
- if [[ "${CARCH}" = 'x86_64' ]] || [[ "${CARCH}" = 'i686' ]]; then
- if [[ "${_XEN}" = '1' ]]; then
- echo "Build grub ${_XEN_ARCH} XEN stuff..."
- _build_grub-xen
- if [[ "${_IA32_XEN_IN_ARCH_X64}" = '1' ]]; then
- echo 'Build grub i386 XEN stuff...'
- _XEN_ARCH='i386' _build_grub-xen
- fi
- fi
- echo 'Build grub BIOS stuff...'
- _build_grub-bios
- echo 'Build grub QEMU stuff...'
- _build_grub-qemu
- echo 'Build grub IEEE1275 (OpenFirmware) stuff...'
- _build_grub-ieee1275
- echo 'Build grub Libreboot stuff...'
- _build_grub-libreboot
- echo 'Build grub Multiboot stuff...'
- _build_grub-multiboot
- elif [[ "${CARCH}" = 'armv7h' ]]; then
- echo 'Build grub U-Boot stuff...'
- _build_grub-uboot
- fi
- if [[ "${_GRUB_EMU_BUILD}" = '1' ]]; then
- echo 'Build grub emu stuff...'
- _build_grub-emu
- fi
- }
- _package_grub-efi() {
- cd "${srcdir}/grub-efi-${_EFI_ARCH}/"
- echo "Run make install for ${_EFI_ARCH} EFI build..."
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo "Remove gdb debugging related files for ${_EFI_ARCH} EFI build..."
- rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/{kernel.exec,gdb_grub,gmodule.pl} || true
- }
- _package_grub-xen() {
- cd "${srcdir}/grub-xen-${_XEN_ARCH}/"
- echo "Run make install for ${_XEN_ARCH} XEN build..."
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo "Remove gdb debugging related files for ${_XEN_ARCH} XEN build..."
- rm -f "${pkgdir}/usr/lib/grub/${_XEN_ARCH}-xen"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/${_XEN_ARCH}-xen"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/${_XEN_ARCH}-xen"/{kernel.exec,gdb_grub,gmodule.pl} || true
- }
- _package_grub-bios() {
- cd "${srcdir}/grub-bios/"
- echo 'Run make install for BIOS build...'
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo 'Remove gdb debugging related files for BIOS build...'
- rm -f "${pkgdir}/usr/lib/grub/i386-pc"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/i386-pc"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/i386-pc"/{kernel.exec,gdb_grub,gmodule.pl} || true
- }
- _package_grub-qemu() {
- cd "${srcdir}/grub-qemu/"
- echo 'Run make install for QEMU build...'
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo 'Remove gdb debugging related files for QEMU build...'
- rm -f "${pkgdir}/usr/lib/grub/i386-qemu"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/i386-qemu"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/i386-qemu"/{kernel.exec,gdb_grub,gmodule.pl} || true
- }
- _package_grub-ieee1275() {
- cd "${srcdir}/grub-ieee1275/"
- echo 'Run make install for IEEE1275 (OpenFirmware) build...'
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo 'Remove gdb debugging related files for IEEE1275 (OpenFirmware) build...'
- rm -f "${pkgdir}/usr/lib/grub/i386-ieee1275"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/i386-ieee1275"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/i386-ieee1275"/{kernel.exec,gdb_grub,gmodule.pl} || true
- }
- _package_grub-libreboot() {
- cd "${srcdir}/grub-libreboot/"
- echo 'Run make install for Libreboot build...'
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo 'Remove gdb debugging related files for Libreboot build...'
- rm -f "${pkgdir}/usr/lib/grub/i386-coreboot"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/i386-coreboot"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/i386-coreboot"/{kernel.exec,gdb_grub,gmodule.pl} || true
- }
- _package_grub-multiboot() {
- cd "${srcdir}/grub-multiboot/"
- echo 'Run make install for Multiboot build...'
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo 'Remove gdb debugging related files for Multiboot build...'
- rm -f "${pkgdir}/usr/lib/grub/i386-multiboot"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/i386-multiboot"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/i386-multiboot"/{kernel.exec,gdb_grub,gmodule.pl} || true
- }
- _package_grub-emu() {
- cd "${srcdir}/grub-emu/"
- echo 'Run make install for emu build...'
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo 'Remove gdb debugging related files for emu build...'
- rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/{kernel.exec,gdb_grub,gmodule.pl} || true
- }
- _package_grub-uboot() {
- cd "${srcdir}/grub-uboot/"
- echo 'Run make install for U-Boot build...'
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo 'Remove gdb debugging related files for U-Boot build...'
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/{kernel.exec,gdb_grub,gmodule.pl} || true
- }
- package_grub() {
- optdepends+=('dosfstools: For grub-mkrescue FAT FS and EFI support'
- 'efibootmgr: For grub-install EFI support'
- 'libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue'
- 'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
- 'mtools: For grub-mkrescue FAT FS support')
- if [[ "${_GRUB_EMU_BUILD}" = '1' ]]; then
- optdepends+=('libusbx: For grub-emu USB support'
- 'sdl: For grub-emu SDL support')
- fi
- cd "${srcdir}/grub/"
- if [[ "${CARCH}" = 'x86_64' ]] || [[ "${CARCH}" = 'i686' ]] || [[ "${CARCH}" = 'armv7h' ]]; then
- echo "Package grub ${_EFI_ARCH} EFI stuff..."
- _package_grub-efi
- if [[ "${CARCH}" = 'x86_64' ]] && [[ "${_IA32_EFI_IN_ARCH_X64}" = '1' ]]; then
- echo 'Package grub i386 EFI stuff...'
- _EFI_ARCH='i386' _package_grub-efi
- fi
- fi
- if [[ "${CARCH}" = 'x86_64' ]] || [[ "${CARCH}" = 'i686' ]]; then
- if [[ "${_XEN}" = '1' ]]; then
- echo "Package grub ${_XEN_ARCH} XEN stuff..."
- _package_grub-xen
- if [[ "${_IA32_XEN_IN_ARCH_X64}" = '1' ]]; then
- echo 'Package grub i386 XEN stuff...'
- _XEN_ARCH='i386' _package_grub-xen
- fi
- fi
- echo 'Package grub BIOS stuff...'
- _package_grub-bios
- echo 'Package grub QEMU stuff...'
- _package_grub-qemu
- echo 'Package grub IEEE1275 (OpenFirmware) stuff...'
- _package_grub-ieee1275
- echo 'Package grub Libreboot stuff...'
- _package_grub-libreboot
- echo 'Package grub Multiboot stuff...'
- _package_grub-multiboot
- elif [[ "${CARCH}" = 'armv7h' ]]; then
- echo 'Package grub U-Boot stuff...'
- _package_grub-uboot
- fi
- if [[ "${_GRUB_EMU_BUILD}" = '1' ]]; then
- echo 'Package grub emu stuff...'
- _package_grub-emu
- fi
- echo 'Install /etc/default/grub (used by grub-mkconfig)...'
- install -D -m0644 "${srcdir}/grub.default" "${pkgdir}/etc/default/grub"
- }
- package_grub-am335x_bone() {
- pkgdesc='GNU GRand Unified Bootloader (2) for BeagleBone and BeagleBone Black (am335x-bone), (Parabola rebranded)'
- optdepends+=('dosfstools: For grub-mkrescue FAT FS'
- 'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
- 'mtools: For grub-mkrescue FAT FS support')
- echo "Copy the source for packaging the U-Boot (am335x-bone) part..."
- cp -r "${srcdir}/grub-uboot/" "${srcdir}/grub-uboot_am335x-bone/"
- cd "${srcdir}/grub-uboot_am335x-bone/"
- echo 'Patch to detect am335x-bone device tree blob file (dtb)...'
- patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch"
- echo 'Package grub U-Boot stuff...'
- ## _package_grub-uboot
- echo 'Run make install for U-Boot build...'
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo 'Remove gdb debugging related files for U-Boot build...'
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/{kernel.exec,gdb_grub,gmodule.pl} || true
- echo 'Install /etc/default/grub (used by grub-mkconfig)...'
- install -D -m0644 "${srcdir}/grub.default" "${pkgdir}/etc/default/grub"
- ## echo 'Patch to detect am335x-bone device tree blob file (dtb)...'
- ## cd "${pkgdir}/etc/grub.d/"
- ## patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch"
- }
- package_grub-omap3_beagle() {
- pkgdesc='GNU GRand Unified Bootloader (2) for BeagleBoard (omap3_beagle), (Parabola rebranded)'
- provides+=('grub-beagleboard')
- optdepends+=('dosfstools: For grub-mkrescue FAT FS'
- 'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
- 'mtools: For grub-mkrescue FAT FS support')
- echo "Copy the source for packaging the U-Boot (omap3_beagle) part..."
- cp -r "${srcdir}/grub-uboot/" "${srcdir}/grub-uboot_omap3_beagle/"
- cd "${srcdir}/grub-uboot_omap3_beagle/"
- echo 'Patch to detect omap3_beagle device tree blob file (dtb)...'
- patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle-devicetree-file.patch"
- echo 'Package grub U-Boot stuff...'
- ## _package_grub-uboot
- echo 'Run make install for U-Boot build...'
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo 'Remove gdb debugging related files for U-Boot build...'
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/{kernel.exec,gdb_grub,gmodule.pl} || true
- echo 'Install /etc/default/grub (used by grub-mkconfig)...'
- install -D -m0644 "${srcdir}/grub.default" "${pkgdir}/etc/default/grub"
- ## echo 'Patch to detect omap3_beagle device tree blob file (dtb)...'
- ## cd "${pkgdir}/etc/grub.d/"
- ## patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle-devicetree-file.patch"
- }
- package_grub-omap3_beagle_xm() {
- pkgdesc='GNU GRand Unified Bootloader (2) for BeagleBoard-xM (omap3_beagle_xm), (Parabola rebranded)'
- provides+=('grub-beagleboard')
- optdepends+=('dosfstools: For grub-mkrescue FAT FS'
- 'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
- 'mtools: For grub-mkrescue FAT FS support')
- echo "Copy the source for packaging the U-Boot (omap3_beagle_xm) part..."
- cp -r "${srcdir}/grub-uboot/" "${srcdir}/grub-uboot_omap3_beagle_xm/"
- cd "${srcdir}/grub-uboot_omap3_beagle_xm/"
- echo 'Patch to detect omap3_beagle_xm device tree blob file (dtb)...'
- patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle_xm-devicetree-file.patch"
- echo 'Package grub U-Boot stuff...'
- ## _package_grub-uboot
- echo 'Run make install for U-Boot build...'
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo 'Remove gdb debugging related files for U-Boot build...'
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/{kernel.exec,gdb_grub,gmodule.pl} || true
- echo 'Install /etc/default/grub (used by grub-mkconfig)...'
- install -D -m0644 "${srcdir}/grub.default" "${pkgdir}/etc/default/grub"
- ## echo 'Patch to detect omap3_beagle_xm device tree blob file (dtb)...'
- ## cd "${pkgdir}/etc/grub.d/"
- ## patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle_xm-devicetree-file.patch"
- }
- package_grub-omap3_beagle_xm_ab() {
- pkgdesc='GNU GRand Unified Bootloader (2) for BeagleBoard-xM rev A/B (omap3_beagle_xm_ab), (Parabola rebranded)'
- provides+=('grub-beagleboard')
- optdepends+=('dosfstools: For grub-mkrescue FAT FS'
- 'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
- 'mtools: For grub-mkrescue FAT FS support')
- echo "Copy the source for packaging the U-Boot (omap3_beagle_xm_ab) part..."
- cp -r "${srcdir}/grub-uboot/" "${srcdir}/grub-uboot_omap3_beagle_xm_ab/"
- cd "${srcdir}/grub-uboot_omap3_beagle_xm_ab/"
- echo 'Patch to detect omap3_beagle_xm_ab device tree blob file (dtb)...'
- patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle_xm_ab-devicetree-file.patch"
- echo 'Package grub U-Boot stuff...'
- ## _package_grub-uboot
- echo 'Run make install for U-Boot build...'
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo 'Remove gdb debugging related files for U-Boot build...'
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/{kernel.exec,gdb_grub,gmodule.pl} || true
- echo 'Install /etc/default/grub (used by grub-mkconfig)...'
- install -D -m0644 "${srcdir}/grub.default" "${pkgdir}/etc/default/grub"
- ## echo 'Patch to detect omap3_beagle_xm_ab device tree blob file (dtb)...'
- ## cd "${pkgdir}/etc/grub.d/"
- ## patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle_xm_ab-devicetree-file.patch"
- }
- package_grub-udoo() {
- pkgdesc='GNU GRand Unified Bootloader (2) for UDOO (udoo), (Parabola rebranded)'
- optdepends+=('dosfstools: For grub-mkrescue FAT FS'
- 'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
- 'mtools: For grub-mkrescue FAT FS support')
- echo "Copy the source for packaging the U-Boot (udoo) part..."
- cp -r "${srcdir}/grub-uboot/" "${srcdir}/grub-uboot_udoo/"
- cd "${srcdir}/grub-uboot_udoo/"
- echo 'Patch to detect udoo device tree blob file (dtb)...'
- patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-udoo-devicetree-file.patch"
- echo 'Package grub U-Boot stuff...'
- ## _package_grub-uboot
- echo 'Run make install for U-Boot build...'
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo 'Remove gdb debugging related files for U-Boot build...'
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/arm-uboot"/{kernel.exec,gdb_grub,gmodule.pl} || true
- echo 'Install /etc/default/grub (used by grub-mkconfig)...'
- install -D -m0644 "${srcdir}/grub.default" "${pkgdir}/etc/default/grub"
- ## echo 'Patch to detect udoo device tree blob file (dtb)...'
- ## cd "${pkgdir}/etc/grub.d/"
- ## patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-udoo-devicetree-file.patch"
- }
|