PKGBUILD 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. # Maintainer (Arch): Balló György <ballogyor+arch at gmail dot com>
  2. # Contributor (Arch): Stefano Facchini <stefano.facchini@gmail.com>
  3. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  4. # Contributor : Isaac David <isacdaavid@at@isacdaavid@dot@info>
  5. # Contributor: Daniel Milewski <niitotantei@gmail.com>
  6. # Contributor : André Silva <emulatorman@hyperbola.info>
  7. # Parabola changes and rationale:
  8. # - Remove download links of nonfree OS
  9. # - Replace Windows with Parabola in documention
  10. pkgname=gnome-boxes
  11. pkgver=3.34.3
  12. pkgrel=2
  13. pkgrel+=.par1
  14. pkgdesc="Simple GNOME application to access remote or virtual systems"
  15. pkgdesc+=", without suggestions (and logos) of nonfree operating systems"
  16. arch=('x86_64')
  17. arch+=('i686' 'armv7h')
  18. url="https://wiki.gnome.org/Apps/Boxes"
  19. license=('LGPL')
  20. conflicts=(${pkgname}-libre)
  21. replaces=(${pkgname}-libre)
  22. groups=('gnome')
  23. depends=('cdrtools' 'gtk-vnc' 'libarchive' 'libgudev' 'libosinfo' 'libsecret'
  24. 'libvirt-glib' 'mtools' 'qemu' 'spice-gtk' 'tracker' 'webkit2gtk' 'freerdp')
  25. makedepends=('git' 'gobject-introspection' 'yelp-tools' 'meson' 'spice-protocol' 'vala')
  26. _commit=c3bce5984eb53cc883850969f3e4a3e8e2cc6d44 # tags/v3.34.3^0
  27. source=("git+https://gitlab.gnome.org/GNOME/gnome-boxes.git#commit=$_commit"
  28. "git+https://gitlab.gnome.org/GNOME/gtk-frdp.git"
  29. "git+https://gitlab.gnome.org/felipeborges/libovf-glib.git")
  30. source+=(hide_download_button.patch)
  31. sha256sums=('SKIP'
  32. 'SKIP'
  33. 'SKIP')
  34. sha256sums+=('0539b344dc0bc8424539f747ed9c638ea414fe96153b803dae50bf5bf2d5aae5')
  35. pkgver() {
  36. cd $pkgname
  37. git describe --tags | sed 's/^v//;s/-/+/g'
  38. }
  39. prepare() {
  40. cd $pkgname
  41. git submodule init
  42. git config --local submodule.subprojects/gtk-frdp.url "$srcdir/gtk-frdp"
  43. git config --local submodule.subprojects/libovf-glib.url "$srcdir/libovf-glib"
  44. git submodule update
  45. # remove recommended downloads of nonfree OS
  46. sed -i /os_id/d ./data/recommended-downloads.xml
  47. # Make download button invisible
  48. patch -Np1 -i ../hide_download_button.patch
  49. # I'd rather not use Windows as example in user docs
  50. find ./help/ -type f \( -name '*.po' -o -name '*.page' \) -exec \
  51. sed -Ei 's/(Microsoft )?Windows(™)?/Parabola/' {} +
  52. }
  53. build() {
  54. arch-meson $pkgname build
  55. ninja -C build
  56. }
  57. check() {
  58. meson test -C build --print-errorlogs
  59. }
  60. package() {
  61. DESTDIR="$pkgdir" meson install -C build
  62. }