PKGBUILD 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Maintainer (Arch): Maxime Gauduin <alucryd@archlinux.org>
  2. # Contributor (Arch): mortzu <me@mortzu.de>
  3. # Contributor (Arch): fnord0 <fnord0@riseup.net>
  4. # Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
  5. # Contributor (Hyperbola): Márcio Silva <coadde@hyperbola.info>
  6. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  7. _basekernel=5.12.6
  8. pkgname=acpi_call-dkms
  9. pkgver=1.2.1
  10. pkgrel=4
  11. pkgrel+=.parabola1.basekernel${_basekernel}
  12. pkgdesc='A linux kernel module that enables calls to ACPI methods through /proc/acpi/call - module sources'
  13. pkgdesc+=' (for linux-libre)'
  14. url=https://github.com/nix-community/acpi_call
  15. arch=(x86_64 i686)
  16. license=(GPL)
  17. depends=(dkms)
  18. makedepends=(git)
  19. provides=(acpi_call=${pkgver}-${pkgrel%%.*})
  20. conflicts=(acpi_call)
  21. _tag=3a28aabfa337d59df91cc04c85b250da7f7cadea
  22. source=(
  23. git+https://github.com/nix-community/acpi_call.git#tag=${_tag}
  24. dkms.conf
  25. )
  26. b2sums=('SKIP'
  27. '504da1102e778fe54368e990408dbef02f5b2ce91f683d170f3d6a1a2f9349d00d61dcbddd0262a8dfc958ea0964135ba58d8dd88ac06bd10b5e13b90f11faef')
  28. pkgver() {
  29. cd acpi_call
  30. git describe --tags | sed 's/^v//'
  31. }
  32. package() {
  33. install -Dm 644 acpi_call/{Makefile,acpi_call.c} dkms.conf -t "${pkgdir}"/usr/src/acpi_call-${pkgver}
  34. echo acpi_call | install -Dm 644 /dev/stdin "${pkgdir}"/usr/lib/modules-load.d/acpi_call.conf
  35. install -dm 755 "${pkgdir}"/usr/share/acpi_call
  36. cp -dr --no-preserve=ownership acpi_call/{examples,support} "${pkgdir}"/usr/share/acpi_call/
  37. }