PKGBUILD 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # U-Boot: BeagleBone and BeagleBone Black
  2. # Maintainer: André Silva <emulatorman@hyperbola.info>
  3. buildarch=4
  4. pkgname=uboot4grub-am335x_bone
  5. pkgver=2015.04
  6. pkgrel=4
  7. pkgdesc="U-Boot with GRUB support for BeagleBone and BeagleBone Black"
  8. arch=('armv7h')
  9. url="http://git.denx.de/u-boot.git/"
  10. depends=('grub-am335x_bone')
  11. conflicts=('uboot-beaglebone-linux-libre' 'uboot-beaglebone-linux-libre-lts'
  12. 'uboot-beaglebone-linux-libre-grsec' 'uboot-beaglebone-linux-libre-pck'
  13. 'uboot-beaglebone' 'uboot-am335x_bone' 'uboot4extlinux-am335x_bone')
  14. makedepends=('bc')
  15. license=('GPL')
  16. install=${pkgname}.install
  17. source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
  18. '0001-parabola-arm-modifications+grub-support.patch'
  19. 'uEnv.txt')
  20. md5sums=('570bdc2c47270c2a98ca60ff6c5c74cd'
  21. '109779c2b15013d54dc2f576651219e4'
  22. 'ccb79775b81654e16fca18825c7f2506')
  23. prepare() {
  24. cd u-boot-${pkgver}
  25. patch -Np1 -i ../0001-parabola-arm-modifications+grub-support.patch
  26. }
  27. build() {
  28. cd u-boot-${pkgver}
  29. unset CFLAGS CXXFLAGS LDFLAGS
  30. make distclean
  31. make am335x_evm_config
  32. make
  33. }
  34. package() {
  35. cd u-boot-${pkgver}
  36. mkdir -p "${pkgdir}"/boot
  37. cp MLO u-boot.img "${srcdir}"/uEnv.txt "${pkgdir}"/boot
  38. }