PKGBUILD 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. # U-Boot: Boundary Devices Nitrogen6X/Sabre Lite
  2. # Maintainer: André Silva <emulatorman@hyperbola.info>
  3. buildarch=4
  4. pkgname=uboot-nitrogen6q
  5. pkgver=2014.07
  6. pkgrel=1
  7. arch=('armv7h')
  8. pkgdesc="U-Boot for Nitrogen6X/Sabre Lite"
  9. url="https://github.com/boundarydevices/u-boot-imx6/tree/production"
  10. license=('GPL')
  11. makedepends=('bc')
  12. depends=('linux-libre')
  13. replaces=('uboot-boundary' 'uboot-boundary-linux-libre')
  14. conflicts=('uboot4extlinux-nitrogen6q' 'uboot4grub-nitrogen6q')
  15. backup=('6x_bootscript')
  16. _commit=bb9dde563768731423fd6c560e95e1793a90710a
  17. source=("https://github.com/boundarydevices/u-boot-imx6/archive/${_commit}.tar.gz"
  18. '0001-parabola-arm-modifications.patch'
  19. '0002-kernel-add-support-for-gcc-5.patch'
  20. '0003-ARM-asm-io.h-use-static-inline.patch'
  21. '0004-common-main.c-make-show_boot_progress-__weak.patch'
  22. '0005-common-board-use-__weak.patch'
  23. '0006-common-board_f-cosmetic-use-__weak-for-leds.patch'
  24. '6x_bootscript')
  25. md5sums=('b12f5f383c57de06f16625b3465e74d9'
  26. '56466a99abaa51e000ec1b133078e084'
  27. '721a46867e189d8dedc6b6f86a536a34'
  28. 'f6b687eca2d2d01f741cbda90dbacb41'
  29. '8087672256020417438b12ec4946e1cf'
  30. 'a536d28bf45add6dbf9f84277f943de8'
  31. '2823d0e0c3c826632f6ae934f2b746d9'
  32. '5744da960a968fef3d078a32a63714d3')
  33. prepare() {
  34. cd u-boot-imx6-${_commit}
  35. patch -Np1 -i ../0001-parabola-arm-modifications.patch
  36. patch -Np1 -i ../0002-kernel-add-support-for-gcc-5.patch
  37. patch -Np1 -i ../0003-ARM-asm-io.h-use-static-inline.patch
  38. patch -Np1 -i ../0004-common-main.c-make-show_boot_progress-__weak.patch
  39. patch -Np1 -i ../0005-common-board-use-__weak.patch
  40. patch -Np1 -i ../0006-common-board_f-cosmetic-use-__weak-for-leds.patch
  41. }
  42. build() {
  43. cd u-boot-imx6-${_commit}
  44. unset CFLAGS
  45. unset CXXFLAGS
  46. make distclean
  47. make nitrogen6q_config
  48. make
  49. }
  50. package() {
  51. cd u-boot-imx6-${_commit}
  52. mkdir -p "${pkgdir}"/boot
  53. cp u-boot.imx "${pkgdir}"/boot
  54. tools/mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "boot script" -d ../6x_bootscript ${pkgdir}/6x_bootscript
  55. }