1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950 |
- # Mainainer: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
- # Contributor: Allan McRae <allan@archlinux.org>
- # Contributor: Andreas Radke <andyrtr@archlinux.org>
- pkgname=tar
- pkgver=1.30
- pkgrel=1
- pkgdesc='Utility used to store, backup, and transport files'
- arch=('x86_64' 'ppc64le')
- url='https://www.gnu.org/software/tar/'
- license=('GPL3')
- groups=('base')
- depends=('glibc' 'acl' 'attr')
- options=('!emptydirs')
- validpgpkeys=('325F650C4C2B6AD58807327A3602B07F55D0C732') # Sergey Poznyakoff
- source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
- md5sums=('2d01c6cd1387be98f57a0ec4e6e35826'
- 'SKIP')
- prepare() {
- cd $pkgname-$pkgver
- # apply patch from the source array (should be a pacman feature)
- local filename
- for filename in "${source[@]}"; do
- if [[ "$filename" =~ \.patch$ ]]; then
- msg2 "Applying patch ${filename##*/}"
- patch -p1 -N -i "$srcdir/${filename##*/}"
- fi
- done
- :
- }
- build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr --libexecdir=/usr/lib/tar
- make
- }
- check() {
- cd $pkgname-$pkgver
- make check
- }
- package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
- }
- # vim:set ts=2 sw=2 et:
|