123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140 |
- # Maintainer: David P. <megver83@parabola.nu>
- # Maintainer (Arch): Sébastien Luttringer
- # Contributor (Arch): Tom Gundersen <teg@jklm.no>
- pkgname=filesystem
- pkgver=2020.09.03
- pkgrel=1
- pkgrel+=.nonsystemd1
- pkgdesc='Base Parabola GNU/Linux-libre files'
- arch=('x86_64')
- arch+=('armv7h' 'i686' 'ppc64le')
- license=('GPL')
- url='https://www.parabola.nu'
- depends=('iana-etc')
- backup=('etc/crypttab' 'etc/fstab' 'etc/group' 'etc/gshadow' 'etc/host.conf'
- 'etc/hosts' 'etc/issue' 'etc/ld.so.conf' 'etc/motd' 'etc/nsswitch.conf'
- 'etc/passwd' 'etc/profile' 'etc/resolv.conf' 'etc/securetty'
- 'etc/shadow' 'etc/shells')
- source=('crypttab' 'env-generator' 'fstab' 'group' 'gshadow' 'host.conf' 'hosts'
- 'issue' 'ld.so.conf' 'locale.sh' 'motd' 'nsswitch.conf' 'os-release'
- 'passwd' 'profile' 'resolv.conf' 'securetty' 'shadow' 'shells' 'sysctl'
- 'sysusers' 'tmpfiles' 'parabola.svg' 'parabola.png'
- 'parabola-logo.svg' 'parabola-logo.png')
- sha256sums=('e03bede3d258d680548696623d5979c6edf03272e801a813c81ba5a5c64f4f82'
- 'ed0cb4f1db4021f8c3b5ce78fdf91d2c0624708f58f36c9cf867f4d93c3bc6da'
- 'e54626e74ed8fee4173b62a545ab1c3a3a069e4217a0ee8fc398d9933e9c1696'
- '244f0718ee2a9d6862ae59d6c18c1dd1568651eada91a704574fa527fbac2b3a'
- '90d879374f77bac47f132164c1e7fc4892e994ff1d1ac376efa0c1c26ea37273'
- '4d7b647169063dfedbff5e1e22cee77bd1a4183dbcfd5e802e68939da4bbf733'
- 'd9cd8a77d9e0aa5e90d7f4ed74c8745c17b525e720e28e4c44364150003c35f9'
- '8b8f24af3454e87b4e316b4978d0de7958a98cc44606aa801d9696d2c21f4385'
- 'dad04a370e488aa85fb0a813a5c83cf6fd981ce01883fc59685447b092de84b5'
- '8ca2d8eef6fb5143c9ef7e9174ccfef59ac7ad2deee243574cd10c763156cc10'
- 'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855'
- 'aa4dc5b2374fb32863e3bc1ce20a2de2d34fe4eed1cd63c599bc82fab21463cc'
- '1fb18c22836c5b679d183a504e594f14d2fdbeb7ce97dd3de5a0c88299f3d597'
- '5e06477834f51abf42ea4e8dc199632afc6afbfd8c44354685a271e9a48d2c0a'
- '5e4088ad8d0853d390fa303f6be8c3f69c33834200cba9e90f7849f1993ca8d0'
- '5557d8e601b17a80d1ea7de78a9869be69637cb6a02fbfe334e22fdf64e61d4c'
- 'd88be2b45b43605ff31dd83d6a138069b6c2e92bc8989b7b9ab9eba8da5f8c7b'
- '6e13705ac4d6f69cdba118c6b70c722346fd3c45224133e6bbfe28aca719563c'
- 'c390b31fffc4a2b5d78ae8c89f5317aadef1f71baac09cfb467b675db1406d61'
- '89e43a0b7028f52d5c8e7fb961d962c4b4f4e9595880a6157274ddb2c7c0b6b4'
- 'efe43c88d70ef55c4461d06a63f682cf1e95bd13b585f14d9061517b07d85669'
- '618ac097441c1f2daffc9967e5c3cd18ea8866f776db62d04bf401c53907b1c9'
- 'cb8ece3772744ef162d0ff6018e6a7051889c2aba1bf6439ba9e74a64ac46927'
- '826c61cb40bb0b31e2071b21e04ad7f8c6aabe2817e681246569ae9dff81cd9b'
- 'cb8ece3772744ef162d0ff6018e6a7051889c2aba1bf6439ba9e74a64ac46927'
- '826c61cb40bb0b31e2071b21e04ad7f8c6aabe2817e681246569ae9dff81cd9b')
- package() {
- cd "$pkgdir"
- # setup root filesystem
- for d in boot dev etc home mnt usr var opt srv/http run; do
- install -d -m755 $d
- done
- install -d -m555 proc
- install -d -m555 sys
- install -d -m0750 root
- install -d -m1777 tmp
- # vsftpd won't run with write perms on /srv/ftp
- # ftp (uid 14/gid 11)
- install -d -m555 -g 11 srv/ftp
- # setup /etc and /usr/share/factory/etc
- install -d etc/{ld.so.conf.d,skel,profile.d} usr/share/factory/etc
- for f in fstab group host.conf hosts issue ld.so.conf motd nsswitch.conf \
- passwd resolv.conf securetty shells profile; do
- install -m644 "$srcdir"/$f etc/
- install -m644 "$srcdir"/$f usr/share/factory/etc/
- done
- ln -s ../proc/self/mounts etc/mtab
- for f in gshadow shadow crypttab; do
- install -m600 "$srcdir"/$f etc/
- install -m600 "$srcdir"/$f usr/share/factory/etc/
- done
- touch etc/parabola-release
- ln -sv parabola-release etc/arch-release
- install -m644 "$srcdir"/locale.sh etc/profile.d/locale.sh
- install -Dm644 "$srcdir"/os-release usr/lib/os-release
- # setup /var
- for d in cache local opt log/old lib/misc empty; do
- install -d -m755 var/$d
- done
- install -d -m1777 var/{tmp,spool/mail}
- # allow setgid games (gid 50) to write scores
- install -d -m775 -g 50 var/games
- ln -s spool/mail var/mail
- ln -s ../run var/run
- ln -s ../run/lock var/lock
- # setup /usr hierarchy
- for d in bin include lib share/{misc,pixmaps} src; do
- install -d -m755 usr/$d
- done
- for d in {1..8}; do
- install -d -m755 usr/share/man/man$d
- done
- # add lib symlinks
- ln -s usr/lib lib
- [[ $CARCH = 'x86_64' ]] && {
- ln -s usr/lib lib64
- ln -s lib usr/lib64
- }
- [[ $CARCH = 'powerpc64le' ]] && {
- ln -s usr/lib lib64
- ln -s lib usr/lib64
- }
- # add bin symlinks
- ln -s usr/bin bin
- ln -s usr/bin sbin
- ln -s bin usr/sbin
- # setup /usr/local hierarchy
- for d in bin etc games include lib man sbin share src; do
- install -d -m755 usr/local/$d
- done
- ln -s ../man usr/local/share/man
- # setup sysctl
- install -D -m644 "$srcdir"/sysctl usr/lib/sysctl.d/10-arch.conf
- # setup opensysusers
- install -D -m644 "$srcdir"/sysusers usr/lib/sysusers.d/arch.conf
- # setup opentmpfiles
- install -D -m644 "$srcdir"/tmpfiles usr/lib/tmpfiles.d/arch.conf
- # setup systemd.environment-generator
- # (env-generator is not used for nonsystemd)
- # add logo
- install -D -m644 "$srcdir"/parabola{,-logo}.{svg,png} usr/share/pixmaps
- }
|