PKGBUILD 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293
  1. # Maintainer: David P. <megver83@parabola.nu>
  2. # Maintainer (Arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
  3. # Contributor (Arch): Jan de Groot <jgc@archlinux.org>
  4. # Contributor (Arch): Tom Gundersen <teg@jklm.no>
  5. # Contributor (Arch): Link Dupont <link@subpop.net>
  6. pkgname=dbus
  7. pkgver=1.12.20
  8. pkgrel=1
  9. pkgrel+=.nonsystemd2
  10. pkgdesc="Freedesktop.org message bus system"
  11. url="https://wiki.freedesktop.org/www/Software/dbus/"
  12. arch=(x86_64)
  13. arch+=(i686 armv7h)
  14. license=(GPL custom)
  15. depends=(libx11 libelogind expat audit)
  16. depends+=(libelogind.so libaudit.so)
  17. makedepends=(elogind xmlto docbook-xsl python yelp-tools doxygen git autoconf-archive)
  18. provides=(libdbus libdbus-1.so)
  19. provides+=(dbus-elogind dbus-openrc)
  20. conflicts=(libdbus dbus-elogind dbus-openrc)
  21. replaces=(${conflicts[@]})
  22. source=("git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-$pkgver"
  23. dbus-enable-elogind.patch
  24. no-fatal-warnings.diff
  25. dbus-reload.hook
  26. dbus.initd)
  27. sha256sums=('SKIP'
  28. 'faffcaa5b295f49fcedeed2c9ece5298949096be3062fd99a4bf1a6ac3ad1ea0'
  29. '6958eeec07557b92a28419eb1702331ee2f0a6fd17285e37dfb6130b9fa4cf6e'
  30. '1335a86bb5eb68614bf13af314f1a7f5f6f68253584986e9c5b492a4585ab722'
  31. '9964aa935b4a7d64f5970bcfcd561b06013a85ae2712444bc4c5f644364dab3b')
  32. validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90') # Simon McVittie <simon.mcvittie@collabora.co.uk>
  33. prepare() {
  34. cd dbus
  35. patch -Np 1 -i ../dbus-enable-elogind.patch
  36. # Allow us to enable checks without them being fatal
  37. patch -Np1 -i ../no-fatal-warnings.diff
  38. NOCONFIGURE=1 ./autogen.sh
  39. }
  40. build() {
  41. cd dbus
  42. ./configure \
  43. --prefix=/usr \
  44. --sysconfdir=/etc \
  45. --localstatedir=/var \
  46. --libexecdir=/usr/lib/dbus-1.0 \
  47. --with-console-auth-dir=/run/console/ \
  48. --with-dbus-user=dbus \
  49. --with-system-pid-file=/run/dbus/pid \
  50. --with-system-socket=/run/dbus/system_bus_socket \
  51. --without-systemdsystemunitdir \
  52. --enable-inotify \
  53. --enable-libaudit \
  54. --disable-systemd \
  55. --disable-user-session \
  56. --enable-xml-docs \
  57. --enable-doxygen-docs \
  58. --enable-ducktype-docs \
  59. --disable-static \
  60. --enable-elogind \
  61. --enable-x11-autolaunch
  62. make
  63. }
  64. check() {
  65. make -C dbus check
  66. }
  67. package() {
  68. DESTDIR="$pkgdir" make -C dbus install
  69. rm -r "$pkgdir"/{etc,var}
  70. # We have a pre-assigned uid (81)
  71. echo 'u dbus 81 "System Message Bus"' |
  72. install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/dbus.conf"
  73. install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
  74. # Remove docs
  75. rm -r "$pkgdir/usr/share/doc"
  76. # Init script
  77. install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
  78. install -Dm755 "$srcdir/dbus.initd" "$pkgdir/etc/init.d/dbus"
  79. install -d "${pkgdir}/etc/runlevels/default"
  80. ln -sf "/etc/init.d/dbus" "${pkgdir}/etc/runlevels/default/dbus"
  81. }