PKGBUILD 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Maintainer: Luke Shumaker <lukeshu@parabola.nu>
  2. pkgname=(parabolaweb-utils parabolaweb-dev)
  3. pkgver=20190407.1
  4. pkgdesc="Utilities for managing the ParabolaWeb website application"
  5. url="https://git.parabola.nu/packages/parabolaweb-utils.git/"
  6. license=('GPL2')
  7. makedepends=('python-pip')
  8. # The commit to get dependency info for
  9. # Bump pkgrel instead of pkgver if updating this is the only change
  10. _parabolaweb_commit=f013c8d8cb06f7c993bbc41519de5ab7dd2ce0c4
  11. pkgrel=1
  12. epoch=1
  13. arch=('i686' 'x86_64' 'armv7h')
  14. source=("https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig}
  15. "requirements_prod-${_parabolaweb_commit}.txt::https://git.parabola.nu/server/parabolaweb.git/plain/requirements_prod.txt?id=${_parabolaweb_commit}"
  16. "requirements-${_parabolaweb_commit}.txt::https://git.parabola.nu/server/parabolaweb.git/plain/requirements.txt?id=${_parabolaweb_commit}")
  17. sha256sums=('c352e225d65597066cb986db263461cf5bc3d317b459b38fcea4212cabae7fa3'
  18. 'SKIP'
  19. '67cf8fb90fd7f0e465d68b05ce3ff3d74ea5b0defd2bd26e0b46e66f3e44e380'
  20. '8d8b7dae5a36471e0db0832a0ac315409ef43972d98223a6ad4db038991dc7fb')
  21. validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9') # Luke Shumaker
  22. prepare() {
  23. cd "$srcdir"
  24. ln -sf requirements-${_parabolaweb_commit}.txt requirements.txt
  25. ln -sf requirements_prod-${_parabolaweb_commit}.txt requirements_prod.txt
  26. }
  27. build() {
  28. cd "$srcdir/$pkgname-$pkgver"
  29. prod_file=../requirements_prod.txt make
  30. }
  31. package_parabolaweb-utils() {
  32. cd "$srcdir/$pkgbase-$pkgver"
  33. depends=($(< depends.txt))
  34. backup=('etc/conf.d/parabolaweb'
  35. 'etc/uwsgi/parabolaweb.ini'
  36. 'etc/sudoers.d/10-parabolaweb')
  37. make install DESTDIR="$pkgdir"
  38. }
  39. package_parabolaweb-dev() {
  40. cd "$srcdir/$pkgbase-$pkgver"
  41. pkgdesc="Depends on packages needed to develop ParabolaWeb"
  42. depends=($(sed -r -e 's/\s*#.*//' depends_make.txt))
  43. }