PKGBUILD 3.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495
  1. # Maintainer (Arch): Xavier Devlamynck <magicrhesus@ouranos.be>
  2. # Contributors (Arch): Keshav P R, atommix aka Aleks Lifey, Xavion, Ananda Samaddar, Dan Serban, Xyne
  3. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  4. # Contributor: André Silva <emulatorman@hyperbola.info>
  5. # Contributor: Márcio Silva <coadde@hyperbola.info>
  6. # parabola changes and rationale:
  7. # - removing support for possibly unsafe protocols
  8. # - fix usage of "open source" and "linux" terms
  9. pkgname=jitsi
  10. pkgver=2.10.5550
  11. pkgrel=7
  12. pkgrel+=.nonprism1
  13. pkgdesc="An audio/video SIP VoIP phone and instant messenger written in Java (formerly SIP-Communicator), without support for unsafe and dangerous for privacy protocols"
  14. arch=('any')
  15. url="http://jitsi.org"
  16. license=('Apache')
  17. depends=('java-runtime=8')
  18. makedepends=('ant' 'java-environment=8')
  19. options=(!strip !emptydirs zipman !libtool docs)
  20. source=("https://download.jitsi.org/jitsi/src/jitsi-src-${pkgver}.zip"
  21. jitsi.desktop
  22. jitsi.sh
  23. nonprism.patch)
  24. sha256sums=('cdfc6f038d1b877c42d26dba1864ac7c6b554dd55c18767a29f2db3618647287'
  25. '61e3bec3470790fa067f87d978016ec4452a6fd3dfba2c9afa5245b58d3cb19d'
  26. 'b22ae316fece079ce7f56060f79722d74867562ec12b9a5279d144eb359587c9'
  27. '437c550c93688efb7f5bec5564093193a663257f9f455fcd5551106db23b2ed3')
  28. prepare() {
  29. cd $srcdir/$pkgname
  30. # remove Open Source term
  31. sed -i 's|Open Source / ||;
  32. s|open source / ||;
  33. s|Open Source|Free Software|;
  34. s|open source|free software|;
  35. ' $(grep -ril 'open source')
  36. sed -i 's|OpenSource / ||;
  37. s|opensource / ||;
  38. s|OpenSource|FreeSoftware|;
  39. s|opensource|freesoftware|;
  40. ' $(grep -ril opensource)
  41. # remove Linux term
  42. sed -i '/, Linux/ s|Linux|GNU/Linux|;
  43. /And Linux/ s|Linux|GNU/Linux|;
  44. /and Linux/ s|Linux|GNU/Linux|;
  45. /For Linux/ s|Linux|GNU/Linux|;
  46. /for Linux/ s|Linux|GNU/Linux|;
  47. /Linux,/ s|Linux|GNU/Linux|;
  48. /Linux and/ s|Linux|GNU/Linux|;
  49. /Linux distribution/ s|Linux|GNU/Linux|;
  50. /Linux machine/ s|Linux|GNU/Linux|;
  51. /Linux operating/ s|Linux|GNU/Linux|;
  52. /Linux OS/ s|Linux|GNU/Linux|;
  53. /Linux specific/ s|Linux|GNU/Linux|;
  54. /Linux system/ s|Linux|GNU/Linux|;
  55. /Under Linux/ s|Linux|GNU/Linux|;
  56. /under Linux/ s|Linux|GNU/Linux|;
  57. /On Linux/ s|Linux|GNU/Linux|;
  58. /on Linux/ s|Linux|GNU/Linux|;
  59. s|GNU/GNU|GNU|;
  60. s|GNU/Linux kernel|Linux kernel|;
  61. s|GNU/Linux specific kernel|Linux specific kernel|;
  62. ' $(grep -rl Linux)
  63. # remove support for unsafe and dangerous for privacy protocols (AIM, Facebook, Google Talk, ICQ, MSN and Yahoo!)
  64. patch -Np1 -i $srcdir/nonprism.patch
  65. }
  66. build() {
  67. cd "${srcdir}/${pkgname}"
  68. # append the build revision to the jitsi version
  69. sed -i "s/0\.build\.by\.SVN/build.${pkgver}/" src/net/java/sip/communicator/impl/version/NightlyBuildID.java
  70. ant rebuild
  71. }
  72. package() {
  73. cd "${srcdir}/${pkgname}"
  74. find lib/ lib/bundle/ -maxdepth 1 -type f -exec install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/"{} \;
  75. # find lib/os-specific/linux/ -maxdepth 1 -type f -execdir install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/lib/"{} \;
  76. shopt -sq extglob
  77. find lib/native/linux$(sed 's/_/-/g' <<<${CARCH/#*(i?86|x86)/})/ -maxdepth 1 -type f -execdir install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/lib/native/"{} \;
  78. find sc-bundles/{,os-specific/linux/} -maxdepth 1 -type f -execdir install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/sc-bundles/"{} \;
  79. install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
  80. install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
  81. cd "resources/install/debian/"
  82. for _file in *.{svg,xpm}; do
  83. install -Dm644 "$_file" "${pkgdir}/usr/share/pixmaps/${_file}"
  84. done
  85. }