PKGBUILD 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. # $Id$
  2. # Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
  3. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  4. # Contributor: Márcio Silva <coadde@hyperbola.info>
  5. # Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
  6. # parabola changes and rationale:
  7. # - removed support for possibly unsafe protocols
  8. pkgname=gnome-online-accounts
  9. pkgver=3.34.1
  10. pkgrel=1.nonprism1
  11. pkgdesc="Single sign-on framework for GNOME, without support for unsafe and dangerous for privacy protocols"
  12. url="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
  13. arch=(x86_64 i686 armv7h)
  14. license=(LGPL)
  15. depends=(webkit2gtk json-glib libnotify rest libsecret telepathy-glib krb5 gcr)
  16. makedepends=(gobject-introspection gtk-doc vala autoconf-archive gnome-common git)
  17. optdepends=('gvfs-goa: Virtual file systems (e.g. OwnCloud)')
  18. _commit=a57487846b75dccd7a272f8682d647766ce222cd # tags/3.34.1^0
  19. source=("git+https://git.gnome.org/browse/gnome-online-accounts#commit=$_commit"
  20. "git+https://git.gnome.org/browse/telepathy-account-widgets")
  21. sha256sums=('SKIP'
  22. 'SKIP')
  23. pkgver() {
  24. cd $pkgname
  25. git describe --tags | sed 's/-/+/g'
  26. }
  27. prepare() {
  28. cd $pkgname
  29. git submodule init
  30. git config --local submodule.telepathy-account-widgets.url "$srcdir/telepathy-account-widgets"
  31. git submodule update
  32. NOCONFIGURE=1 ./autogen.sh
  33. }
  34. build() {
  35. cd $pkgname
  36. ./configure \
  37. --prefix=/usr \
  38. --libexecdir=/usr/lib \
  39. --disable-static \
  40. --enable-compile-warnings=minimum \
  41. --enable-inspector \
  42. --enable-media-server \
  43. --enable-kerberos \
  44. --enable-telepathy \
  45. --enable-owncloud \
  46. --enable-imap-smtp \
  47. --disable-lastfm \
  48. --disable-todoist \
  49. --disable-exchange \
  50. --disable-facebook \
  51. --disable-flickr \
  52. --disable-google \
  53. --disable-pocket \
  54. --disable-windows-live \
  55. --disable-twitter \
  56. --disable-yahoo \
  57. --disable-foursquare \
  58. --enable-gtk-doc
  59. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  60. make
  61. }
  62. package() {
  63. cd $pkgname
  64. make DESTDIR="$pkgdir" install
  65. }