PKGBUILD 704 B

123456789101112131415161718192021222324252627282930313233
  1. # Maintainer: Luke Shumaker <lukeshu@parabola.nu>
  2. pkgname=collectd-systemd
  3. pkgver=20170820
  4. pkgdesc="A collectd plugin to read systemd unit and job counts"
  5. url="https://git.lukeshu.com/$pkgname.git"
  6. license=('GPL')
  7. pkgrel=2
  8. arch=('any')
  9. depends=('collectd' 'systemd' 'python-dbus')
  10. source=("https://repo.parabola.nu/other/~lukeshu/$pkgname/$pkgname-$pkgver.tar.gz")
  11. md5sums=('9a5bf4e8f6f775ae98182a0577c91371')
  12. _config=(
  13. prefix=/usr
  14. )
  15. prepare() {
  16. cd "$srcdir/$pkgname-$pkgver"
  17. sed -Ei 's/collectd([a-z])/collectd_\1/g' Makefile
  18. }
  19. build() {
  20. cd "$srcdir/$pkgname-$pkgver"
  21. make "${_config[@]}"
  22. }
  23. package() {
  24. cd "$srcdir/$pkgname-$pkgver"
  25. make "${_config[@]}" install DESTDIR="$pkgdir"
  26. }