12345678910111213141516171819202122232425262728293031 |
- # Maintainer: Parabola Project <dev@lists.parabola.nu>
- pkgname=your-privacy
- pkgdesc="This package will remove support for protocols and services known to endanger privacy."
- license=('GPL3')
- url="https://git.parabola.nu/blacklist.git"
- pkgver=20211130
- _gitver=ab32447a5a47a2a5ec5a3fa6043dc6b9024e3674
- pkgrel=1
- arch=('any')
- install=${pkgname}.install
- makedepends=(librelib)
- source=(blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_gitver})
- sha512sums=('9ab837a9ca351bb844ecdfc147d69ec1f0d1971fbe12ceeed3b837fc59c54b10d2476901e60f677b0f53166a805b493b0a8bcd638e9e6638012dd454c7930cf8')
- package() {
- cd "$srcdir"
- conflicts=($( \
- < blacklist-${_gitver}.txt \
- libreblacklist normalize | \
- cut -d: -f1,2 | \
- sed -n 's/:$//p' | \
- sort -u \
- ))
- install -Dm644 blacklist-${_gitver}.txt "$pkgdir"/usr/share/doc/${pkgname}/blacklist.txt
- }
|