PKGBUILD 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879
  1. # $Id$
  2. # Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
  3. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  4. # Contributor: Márcio Silva <coadde@hyperbola.info>
  5. # Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
  6. # Maintainers: Parabola hackers <dev@lists.parabola.nu>
  7. # parabola changes and rationale:
  8. # - removed support for possibly unsafe protocols
  9. pkgname=gnome-online-accounts
  10. pkgver=3.34.1
  11. pkgrel=1.nonprism1
  12. pkgdesc="Single sign-on framework for GNOME, without support for unsafe and dangerous for privacy protocols"
  13. url="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
  14. arch=(x86_64 i686 armv7h)
  15. license=(LGPL)
  16. depends=(webkit2gtk json-glib libnotify rest libsecret telepathy-glib krb5 gcr)
  17. makedepends=(gobject-introspection gtk-doc vala autoconf-archive gnome-common git)
  18. optdepends=('gvfs-goa: Virtual file systems (e.g. OwnCloud)')
  19. _commit=a57487846b75dccd7a272f8682d647766ce222cd # tags/3.34.1^0
  20. source=("git+https://git.gnome.org/browse/gnome-online-accounts#commit=$_commit"
  21. "git+https://git.gnome.org/browse/telepathy-account-widgets")
  22. sha256sums=('SKIP'
  23. 'SKIP')
  24. pkgver() {
  25. cd $pkgname
  26. git describe --tags | sed 's/-/+/g'
  27. }
  28. prepare() {
  29. cd $pkgname
  30. git submodule init
  31. git config --local submodule.telepathy-account-widgets.url "$srcdir/telepathy-account-widgets"
  32. git submodule update
  33. NOCONFIGURE=1 ./autogen.sh
  34. }
  35. build() {
  36. cd $pkgname
  37. ./configure \
  38. --prefix=/usr \
  39. --libexecdir=/usr/lib \
  40. --disable-static \
  41. --enable-compile-warnings=minimum \
  42. --enable-inspector \
  43. --enable-media-server \
  44. --enable-kerberos \
  45. --enable-telepathy \
  46. --enable-owncloud \
  47. --enable-imap-smtp \
  48. --disable-lastfm \
  49. --disable-todoist \
  50. --disable-exchange \
  51. --disable-facebook \
  52. --disable-flickr \
  53. --disable-google \
  54. --disable-pocket \
  55. --disable-windows-live \
  56. --disable-twitter \
  57. --disable-yahoo \
  58. --disable-foursquare \
  59. --enable-gtk-doc
  60. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  61. make
  62. }
  63. package() {
  64. cd $pkgname
  65. make DESTDIR="$pkgdir" install
  66. }