PKGBUILD 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. # $Id$
  2. # Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
  3. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  4. # Contributor: André Silva <emulatorman@hyperbola.info>
  5. # Maintainers: Parabola hackers <dev@lists.parabola.nu>
  6. # parabola changes and rationale
  7. # - removed geoclue2 support
  8. pkgname=empathy
  9. pkgver=3.25.90+34+g78f4d4fda
  10. pkgrel=3.nonprism1
  11. pkgdesc="A GNOME instant messaging client using the Telepathy framework, without geoclue2 support"
  12. url="https://wiki.gnome.org/Apps/Empathy"
  13. arch=(x86_64 i686 armv7h)
  14. license=(GPL2)
  15. depends=(clutter-gst clutter-gtk folks gcr iso-codes libcanberra libpulse webkit2gtk
  16. telepathy-farstream telepathy-glib telepathy-logger telepathy-mission-control
  17. geocode-glib cheese libchamplain libgudev)
  18. makedepends=(intltool itstool docbook-xsl python gnome-common git)
  19. optdepends=('telepathy-gabble: XMPP/Jabber support'
  20. 'telepathy-idle: IRC support'
  21. 'telepathy-salut: Link-local XMPP support'
  22. 'telepathy-haze: libpurple support')
  23. _commit=78f4d4fdadd7da67e063c2905649f6a6015ef8f9 # master
  24. source=("git+https://git.gnome.org/browse/empathy#commit=$_commit"
  25. "git+https://git.gnome.org/browse/telepathy-account-widgets"
  26. enchant-2.patch)
  27. sha256sums=('SKIP'
  28. 'SKIP'
  29. 'f177f0dfc242018dd52e312637f513fd08f64aa991b45930cc3ea9a2576f795e')
  30. pkgver() {
  31. cd $pkgname
  32. git describe --tags | sed 's/^EMPATHY_//;s/_/./g;s/-/+/g'
  33. }
  34. prepare() {
  35. cd $pkgname
  36. git submodule init
  37. git config --local submodule.telepathy-account-widgets.url "$srcdir/telepathy-account-widgets"
  38. git submodule update
  39. patch -Np1 -i ../enchant-2.patch
  40. NOCONFIGURE=1 ./autogen.sh
  41. }
  42. build() {
  43. cd $pkgname
  44. export LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
  45. ./configure --prefix=/usr \
  46. --sysconfdir=/etc \
  47. --libexecdir=/usr/lib/empathy \
  48. --disable-static \
  49. --disable-Werror \
  50. --enable-location=no
  51. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  52. make
  53. }
  54. package() {
  55. cd $pkgname
  56. make DESTDIR="$pkgdir" install
  57. }