PKGBUILD 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889
  1. # Maintainer (arch): Jan Alexander Steffens (heftig) heftig@archlinux.org>
  2. # Contributor: Jan de Groot <jgc@archlinux.org>
  3. # Contributor: Tobias Kieslich <tobias@justdreams.de>
  4. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  5. # Contributor: André Silva <emulatorman@hyperbola.info>
  6. # Contributor: Márcio Silva <coadde@hyperbola.info>
  7. # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
  8. # parabola changes and rationale:
  9. # privacy:
  10. # - removed support for possibly unsafe protocols
  11. # technical:
  12. # - use upstream source-ball rather than VCS sources
  13. pkgname=gthumb
  14. pkgver=3.12.4
  15. pkgrel=1
  16. pkgrel+=.nonprism1
  17. pkgdesc="Image browser and viewer for the GNOME Desktop"
  18. pkgdesc+=", without support for unsafe and dangerous for privacy protocols"
  19. url="https://wiki.gnome.org/Apps/gthumb"
  20. arch=(x86_64)
  21. arch+=(armv7h i686)
  22. license=(GPL)
  23. depends=(
  24. clutter-gtk
  25. dconf
  26. gsettings-desktop-schemas
  27. gst-plugin-gtk
  28. gst-plugins-base-libs
  29. json-glib
  30. libheif
  31. libjxl
  32. librsvg
  33. libsecret
  34. libsoup
  35. libwebp
  36. webkit2gtk
  37. )
  38. makedepends=(
  39. brasero
  40. docbook-xsl
  41. exiv2
  42. git
  43. liboauth
  44. libraw
  45. meson
  46. yelp-tools
  47. )
  48. optdepends=(
  49. 'brasero: burn discs'
  50. 'exiv2: metadata support'
  51. 'liboauth: web albums'
  52. 'libraw: read RAW files'
  53. )
  54. # we use source-ball
  55. source=(
  56. https://gitlab.gnome.org/GNOME/gthumb/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz
  57. )
  58. source+=( nonprism.patch )
  59. b2sums=('be952a6ce111137c35501252459e884307e2e43962cf877b30c9fae7ab8af3c8e9341fd0a331201e4eeff829319362362f12079a108ef8f6b1b40adf5304d51c')
  60. b2sums+=('83f8e250b1483ff88ba1d6f12230fb7c3c23b51b9716855192263400c89136d33f513673763ef3e1a53effba3416f0513e96e0a747ccfcc0398280a6a6560270')
  61. prepare() {
  62. ln -s ${pkgname}-${pkgver} $pkgname # minimize diff
  63. cd $pkgname
  64. echo "applying nonprism.patch"
  65. patch --verbose -Np1 -i ../nonprism.patch # disable webservices build
  66. rm ./data/icons/private/hicolor/16x16/actions/site-*.png # delete logos
  67. }
  68. build() {
  69. arch-meson gthumb build
  70. meson compile -C build
  71. }
  72. check() {
  73. meson test -C build --print-errorlogs
  74. }
  75. package() {
  76. meson install -C build --destdir "$pkgdir"
  77. }