PKGBUILD 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Maintainer: Andreas Grapentin <andreas@grapentin.org>
  2. # Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
  3. # Contributor: André Silva <emulatorman@hyperbola.info>
  4. pkgname=gnome-weather
  5. pkgver=3.26.0
  6. pkgrel=1.nonprism1
  7. arch=(any)
  8. pkgdesc="Access current weather conditions and forecasts, without geoclue2 support"
  9. url="https://wiki.gnome.org/Apps/Weather"
  10. license=(GPL)
  11. makedepends=(intltool gobject-introspection autoconf-archive appstream-glib git)
  12. depends=(gtk3 gjs libgweather gnome-desktop)
  13. groups=(gnome-extra)
  14. _commit=608877f993ab001666d9ca843c23c98c16459abe # tags/3.26.0^0
  15. source=("git+https://git.gnome.org/browse/gnome-weather#commit=$_commit"
  16. "nonprism.patch")
  17. sha256sums=('SKIP'
  18. '982ac0d22e5e46adc97d5b9b964a13c3c036f9525b42b05fc56946a1d114f0de')
  19. pkgver() {
  20. cd $pkgname
  21. git describe --tags | sed 's/-/+/g'
  22. }
  23. prepare() {
  24. cd $pkgname
  25. patch -p1 -i $srcdir/nonprism.patch
  26. NOCONFIGURE=1 ./autogen.sh
  27. }
  28. build() {
  29. cd $pkgname
  30. ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  31. make
  32. }
  33. package() {
  34. cd $pkgname
  35. make DESTDIR="$pkgdir" install
  36. }