PKGBUILD 894 B

1234567891011121314151617181920212223242526272829303132
  1. # Maintainer: Parabola Project <dev@lists.parabola.nu>
  2. pkgname=your-freedom
  3. pkgdesc="This package conflicts with every nonfree package known to date to ensure your system is free."
  4. license=('GPL3')
  5. url="https://git.parabola.nu/blacklist.git"
  6. pkgver=20210421
  7. _gitver=93c93bbcf56ae5cff1387c9a93c40cfa81f636ff
  8. pkgrel=1
  9. arch=('any')
  10. install=${pkgname}.install
  11. makedepends=(librelib)
  12. source=(blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/blacklist.txt?id=${_gitver})
  13. sha512sums=('6b0ceb86e53117a18085981f93ca85b16a8ae8b403404bd90ef7160ef5e4e57ef4c1dd607c0072a7d40bd611c070bd612af1424fc471861f204da7a0d0b99ba4')
  14. package() {
  15. cd "$srcdir"
  16. conflicts=($( \
  17. < blacklist-${_gitver}.txt \
  18. libreblacklist normalize | \
  19. cut -d: -f1,2 | \
  20. sed -n 's/:$//p' | \
  21. sort -u \
  22. ))
  23. install -Dm644 blacklist-${_gitver}.txt "$pkgdir"/usr/share/doc/${pkgname}/blacklist.txt
  24. }