1234567891011121314151617181920212223242526272829303132 |
- # Maintainer: Parabola Project <dev@lists.parabola.nu>
- pkgname=your-freedom
- pkgdesc="This package conflicts with every nonfree package known to date to ensure your system is free."
- license=('GPL3')
- url="https://git.parabola.nu/blacklist.git"
- pkgver=20210421
- _gitver=93c93bbcf56ae5cff1387c9a93c40cfa81f636ff
- pkgrel=1
- arch=('any')
- install=${pkgname}.install
- makedepends=(librelib)
- source=(blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/blacklist.txt?id=${_gitver})
- sha512sums=('6b0ceb86e53117a18085981f93ca85b16a8ae8b403404bd90ef7160ef5e4e57ef4c1dd607c0072a7d40bd611c070bd612af1424fc471861f204da7a0d0b99ba4')
- package() {
- cd "$srcdir"
- conflicts=($( \
- < blacklist-${_gitver}.txt \
- libreblacklist normalize | \
- cut -d: -f1,2 | \
- sed -n 's/:$//p' | \
- sort -u \
- ))
- install -Dm644 blacklist-${_gitver}.txt "$pkgdir"/usr/share/doc/${pkgname}/blacklist.txt
- }
|