PKGBUILD 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Maintainer: Luke Shumaker <lukeshu@parabola.nu>
  2. # Maintainer (AUR): Mark Foxwell <fastfret79@archlinux.org.uk>
  3. # Contributor (AUR): Nicolas Martyanoff <khaelin@gmail.com>
  4. # Contributor (AUR): Rick Chen <stuffcorpse@archlinux.us>
  5. # parabola changes and rationale:
  6. # * no significant changes
  7. # * this is in [libre] because it is a dependency of 'libretools'
  8. pkgname=tokyocabinet
  9. pkgver=1.4.48
  10. pkgrel=5
  11. pkgdesc="a modern implementation of DBM"
  12. arch=('i686' 'x86_64' 'armv7h')
  13. url="http://fallabs.com/tokyocabinet/"
  14. license=('LGPL')
  15. depends=('zlib' 'bzip2')
  16. source=("http://fallabs.com/tokyocabinet/${pkgname}-${pkgver}.tar.gz")
  17. sha256sums=('a003f47c39a91e22d76bc4fe68b9b3de0f38851b160bbb1ca07a4f6441de1f90')
  18. build() {
  19. cd "$srcdir/$pkgname-$pkgver"
  20. [ "$CARCH" == "armv7h" ] && sed -i "s/-minline-all-stringops//g" configure
  21. ./configure --prefix=/usr --enable-off64 --enable-fastest
  22. make
  23. }
  24. check() {
  25. cd "$srcdir/$pkgname-$pkgver"
  26. make check
  27. }
  28. package() {
  29. cd "$srcdir/$pkgname-$pkgver"
  30. make DESTDIR="$pkgdir/" install
  31. }