PKGBUILD 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Maintainer (Arch): Maxime Gauduin <alucryd@archlinux.org>
  2. # Contributor (Arch): TingPing <tingping@tingping.se>
  3. # Contributor: André Silva <emulatorman@hyperbola.info>
  4. # Maintainer: Freemor <freemor@freemor.ca>
  5. pkgname=hexchat
  6. pkgver=2.14.3
  7. pkgrel=1
  8. pkgrel+=.parabola1
  9. pkgdesc='A popular and easy to use graphical IRC (chat) client'
  10. pkgdesc+=', without nonfree browser reference'
  11. arch=('x86_64')
  12. arch+=('i686' 'armv7h')
  13. url='https://hexchat.github.io/'
  14. license=('GPL')
  15. depends=('dbus-glib' 'desktop-file-utils' 'gdk-pixbuf2' 'glib2' 'gtk2'
  16. 'libcanberra' 'libnotify' 'libproxy' 'openssl' 'pango' 'pciutils')
  17. makedepends=('git' 'intltool' 'iso-codes' 'lua' 'meson' 'perl' 'python-cffi')
  18. optdepends=('enchant: Spell check'
  19. 'iso-codes: Display language names instead of codes'
  20. 'lua: Lua plugin'
  21. 'perl: Perl plugin'
  22. 'python-cffi: Python plugin')
  23. replaces=(${pkgname}-libre)
  24. conflicts=(${pkgname}-libre)
  25. source=("git+https://github.com/hexchat/hexchat.git#tag=v${pkgver}"
  26. '0002-python-3-8.patch'
  27. 'restore_ctrl-w.patch')
  28. sha256sums=('SKIP'
  29. '8d17ce657e744272815b5fb33d8ad959f79ece3294349637eaadcf86d90496fa'
  30. 'f78f986a064e6c5a8713a219fa042c94bb2b0236869d33b48801faedc9cef63e')
  31. prepare() {
  32. cd hexchat
  33. patch -Np1 < ../0002-python-3-8.patch
  34. # Remove nonfree browser references
  35. sed -i '\|NAME Open Link| s|Firefox|Iceweasel|' src/common/hexchat.c
  36. sed -i '\|NAME Open Link| s|firefox -new-window %s\\n\\n";|iceweasel -new-window %s\\n\\n"\\\n "NAME Open Link in a new Icecat Window\\n" "CMD !icecat -new-window %s\\n\\n";|' src/common/hexchat.c
  37. #Restore CTRL-W
  38. patch -p1 src/fe-gtk/menu.c ../restore_ctrl-w.patch
  39. }
  40. build() {
  41. arch-meson hexchat build \
  42. -Dwith-lua='lua' \
  43. -Dwith-text='true'
  44. ninja -C build
  45. }
  46. package() {
  47. DESTDIR="${pkgdir}" ninja -C build install
  48. }
  49. # vim: ts=2 sw=2 et: