PKGBUILD 2.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. # Maintainer (Arch): Alexander F Rødseth <xyproto@archlinux.org>
  2. # Contributor (Arch): Lukas Fleischer <lfleischer@archlinux.org>
  3. # Contributor (Arch): jlvsimoes <jlvsimoes@oninet.pt>
  4. # Contributor (Arch): kevin <kevin@archlinux.org>
  5. # Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
  6. # Contributor (Hyperbola): Márcio Silva <coadde@hyperbola.info>
  7. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  8. pkgname=abuse
  9. _pkgname=$pkgname-libre
  10. pkgver=0.8
  11. pkgrel=9
  12. pkgrel+=.par1
  13. pkgdesc='Side-scroller action game that pits you against ruthless alien killers, without nonfree claudio support'
  14. arch=('x86_64')
  15. arch+=('i686' 'armv7h')
  16. url='http://abuse.zoy.org/'
  17. license=('GPL' 'custom')
  18. replaces=($_pkgname)
  19. conflicts=($_pkgname)
  20. depends=('desktop-file-utils' 'gcc-libs' 'glu' 'libgl' 'sdl_mixer')
  21. makedepends=('gendesk' 'glu' 'mesa-libgl')
  22. mksource=("http://$pkgname.zoy.org/raw-attachment/wiki/download/$pkgname-$pkgver.tar.gz")
  23. source=("https://repo.parabola.nu/other/$_pkgname/$_pkgname-$pkgver.tar.gz"
  24. "$pkgname.sh"
  25. "default.${pkgname}rc"
  26. 'default.gamma.lsp'
  27. 'libre.patch')
  28. mksha256sums=('0104db5fd2695c9518583783f7aaa7e5c0355e27c5a803840a05aef97f9d3488')
  29. sha256sums=('8f77e8020bf17b10d8a5269d7d4d9bc3592f961ce352672ce183e1f41efc956b'
  30. '8dcf3b6b6ac419e5ffabc847166917d70ce43af3092c4d651f473947fff0cc7d'
  31. '6ea2fa9e65c10bbcab4432f40d0c7284cb3970835c40c5c00ced14b39ce1b00f'
  32. '13df83fea60918d29d5141cdfbd8d56147c053e88d3701209ae676f46447c2f6'
  33. '7566a3affb01c64ff4f859bcd549661220847e9c62327e71e1d585c0048f90ea')
  34. mksource() {
  35. cd "$pkgname-$pkgver"
  36. # Remove the nonfree claudio addon
  37. rm -rvf ./data/addon/claudio
  38. }
  39. prepare() {
  40. cd "$pkgname-$pkgver"
  41. patch -p1 -i "$srcdir/libre.patch"
  42. gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc"
  43. }
  44. build() {
  45. cd "$pkgname-$pkgver"
  46. ./configure \
  47. --prefix=/usr \
  48. --with-assetdir="/usr/share/$pkgname/orig" \
  49. --with-x \
  50. --enable-debug # Fix for FS#52915
  51. make
  52. }
  53. package() {
  54. cd "$pkgname-$pkgver"
  55. make DESTDIR="$pkgdir" install
  56. # Desktop shortcut and icon
  57. install -Dm644 "$pkgname.desktop" \
  58. "$pkgdir/usr/share/applications/$pkgname.desktop"
  59. install -Dm644 "doc/$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
  60. # Default configuration
  61. mv "$pkgdir/usr/bin/$pkgname" "$pkgdir/usr/bin/$pkgname.elf"
  62. install -Dm755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
  63. install -Dm644 "$srcdir/default.${pkgname}rc" \
  64. "$pkgdir/usr/share/$pkgname/default.${pkgname}rc"
  65. install -Dm644 "$srcdir/default.gamma.lsp" \
  66. "$pkgdir/usr/share/$pkgname/default.gamma.lsp"
  67. # License (for the original source code)
  68. install -d "$pkgdir/usr/share/licenses/$pkgname"
  69. sed -n '1,/^$/p' src/view.cpp > "$pkgdir/usr/share/licenses/$pkgname/original"
  70. }
  71. # vim:set ts=2 sw=2 et: