PKGBUILD 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # $Id: PKGBUILD 138775 2015-08-26 07:05:31Z spupykin $
  2. # Maintainer (Arch): Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
  3. # Contributor (Arch): solsTiCe d'Hiver <solstice.dhiver@gmail.com>
  4. # Maintainer (Hyperbola): André Silva <emulatorman@hyperbola.info>
  5. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  6. pkgname=lesspipe
  7. pkgver=1.83
  8. pkgrel=2
  9. pkgrel+=.par1
  10. pkgdesc='an input filter for the pager less'
  11. pkgdesc+=', with libarchive recommendation'
  12. depends=('less')
  13. arch=('any')
  14. license=('GPL')
  15. replaces=(${pkgname}-libre)
  16. conflicts=(${pkgname}-libre)
  17. optdepends=('perl'
  18. 'rpmextract: support for rpm files'
  19. 'fastjar: support for jar files'
  20. 'unzip: support for zip files'
  21. 'libarchive: support for rar files'
  22. 'p7zip: support for 7za files'
  23. 'cabextract: support for cab files'
  24. 'cdrkit: support for iso files'
  25. 'html2text: support for html files'
  26. 'antiword: support for word file'
  27. 'unrtf: support for rtf file'
  28. 'imagemagick: support for some image file')
  29. url="http://www-zeuthen.desy.de/~friebel/unix/lesspipe.html"
  30. source=("http://downloads.sourceforge.net/project/lesspipe/lesspipe/$pkgver/lesspipe-$pkgver.tar.gz"
  31. lesspipe.sh)
  32. sha256sums=('d616f0d51852e60fb0d0801eec9c31b10e0acc6fdfdc62ec46ef7bfd60ce675e'
  33. '522a4893b640ed95e39fd4ca83a5d5ec79207542fec03710fa5e73fe201ed057')
  34. build() {
  35. cd "$srcdir"/$pkgname-$pkgver
  36. ./configure --prefix=/usr --yes
  37. make
  38. }
  39. package() {
  40. cd "$srcdir"/$pkgname-$pkgver
  41. mkdir -p "$pkgdir"/usr/share/man/man1
  42. make install PREFIX="$pkgdir"/usr
  43. install -D "$srcdir"/lesspipe.sh "$pkgdir"/etc/profile.d/lesspipe.sh
  44. }