PKGBUILD 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576
  1. # Maintainer: David P. <megver83@parabola.nu>
  2. # Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
  3. pkgname=lib32-dbus
  4. _pkgbasename=dbus
  5. pkgver=1.12.16
  6. pkgrel=1
  7. pkgrel+=.nonsystemd1
  8. pkgdesc="Freedesktop.org message bus system (32-bit)"
  9. url="https://wiki.freedesktop.org/www/Software/dbus/"
  10. arch=(x86_64)
  11. license=(GPL custom)
  12. provides=(lib32-libdbus)
  13. conflicts=(lib32-libdbus)
  14. replaces=(lib32-libdbus)
  15. depends=(dbus)
  16. makedepends=(gcc-multilib lib32-glib2 lib32-expat git autoconf-archive lib32-libx11)
  17. _commit=23cc709db8fab94f11fa48772bff396b20aea8b0 # tags/dbus-1.12.16^0
  18. source=("git+https://gitlab.freedesktop.org/dbus/dbus.git#commit=$_commit")
  19. sha256sums=('SKIP')
  20. validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90' # Simon McVittie <simon.mcvittie@collabora.co.uk>
  21. '3C8672A0F49637FE064AC30F52A43A1E4B77B059') # Simon McVittie <simon.mcvittie@collabora.co.uk>
  22. pkgver() {
  23. cd dbus
  24. git describe --tags | sed 's/^dbus-//;s/-/+/g'
  25. }
  26. prepare() {
  27. cd dbus
  28. NOCONFIGURE=1 ./autogen.sh
  29. }
  30. build() {
  31. export CC="gcc -m32"
  32. export CXX="g++ -m32"
  33. export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
  34. cd dbus
  35. ./configure \
  36. --prefix=/usr \
  37. --sysconfdir=/etc \
  38. --localstatedir=/var \
  39. --libdir=/usr/lib32 \
  40. --libexecdir=/usr/lib/dbus-1.0 \
  41. runstatedir=/run \
  42. --with-console-auth-dir=/run/console/ \
  43. --with-dbus-user=dbus \
  44. --with-system-pid-file=/run/dbus/pid \
  45. --with-system-socket=/run/dbus/system_bus_socket \
  46. --enable-inotify \
  47. --enable-user-session \
  48. --disable-static \
  49. --disable-verbose-mode \
  50. --disable-asserts \
  51. --disable-checks \
  52. --without-systemdsystemunitdir \
  53. --disable-systemd \
  54. --enable-x11-autolaunch
  55. make
  56. }
  57. check() {
  58. make -C dbus check
  59. }
  60. package() {
  61. DESTDIR="$pkgdir" make -C dbus install
  62. rm -r "$pkgdir"/usr/{bin,include,lib,share}
  63. rm -r "$pkgdir"/{etc,var}
  64. install -d "$pkgdir/usr/share/licenses"
  65. ln -s dbus "$pkgdir/usr/share/licenses/$pkgname"
  66. }