PKGBUILD 894 B

1234567891011121314151617181920212223242526272829303132
  1. # Maintainer: Parabola Project <dev@lists.parabola.nu>
  2. pkgname=your-freedom
  3. pkgdesc="This package conflicts with every nonfree package known to date to ensure your system is free."
  4. license=('GPL3')
  5. url="https://git.parabola.nu/blacklist.git"
  6. pkgver=20210430
  7. _gitver=27f2573c1389eff98fe918d54397c0bd3a6561ba
  8. pkgrel=1
  9. arch=('any')
  10. install=${pkgname}.install
  11. makedepends=(librelib)
  12. source=(blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/blacklist.txt?id=${_gitver})
  13. sha512sums=('4c40dfa68e165613cc4a9839122739fdb70cfc1023c0f8f3a1ec2f2b8102fa33068877704004c333821f5c8ac05cd1c3386a9fe3af4a18b2e361764ac1181718')
  14. package() {
  15. cd "$srcdir"
  16. conflicts=($( \
  17. < blacklist-${_gitver}.txt \
  18. libreblacklist normalize | \
  19. cut -d: -f1,2 | \
  20. sed -n 's/:$//p' | \
  21. sort -u \
  22. ))
  23. install -Dm644 blacklist-${_gitver}.txt "$pkgdir"/usr/share/doc/${pkgname}/blacklist.txt
  24. }