PKGBUILD 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121
  1. # Maintainer (Arch): Maxime Gauduin <alucryd@archlinux.org>
  2. # Contributor (Arch): Themaister <maister@archlinux.us>
  3. # Contributor (Arch): lifning <definelightning@gmail.com>
  4. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  5. # Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
  6. # rationale for inclusion in [libre]:
  7. # - removed updated urls (libre.patch)
  8. pkgname=retroarch
  9. pkgver=1.8.5
  10. pkgrel=1
  11. pkgrel+=.parabola1
  12. pkgdesc='Reference frontend for the libretro API'
  13. arch=(x86_64)
  14. arch+=(i686 armv7h)
  15. url=http://www.libretro.com/
  16. license=(GPL)
  17. groups=(libretro)
  18. depends=(
  19. alsa-lib
  20. flac
  21. libass.so
  22. libavcodec.so
  23. libavformat.so
  24. libavutil.so
  25. libdrm
  26. libfreetype.so
  27. libgl
  28. libpulse
  29. libswresample.so
  30. libswscale.so
  31. libudev.so
  32. libusb-1.0.so
  33. mbedtls
  34. mesa
  35. miniupnpc
  36. openal
  37. qt5-base
  38. sdl2
  39. v4l-utils
  40. zlib
  41. )
  42. makedepends=(
  43. git
  44. libx11
  45. libxcb
  46. libxext
  47. libxinerama
  48. libxkbcommon
  49. libxrandr
  50. libxv
  51. libxxf86vm
  52. vulkan-icd-loader
  53. wayland
  54. wayland-protocols
  55. )
  56. optdepends=(
  57. 'libretro-overlays: Collection of overlays'
  58. 'libretro-shaders: Collection of shaders'
  59. 'libxinerama: X11 support'
  60. 'libxrandr: X11 support'
  61. 'python: retroarch-cg2glsl'
  62. 'retroarch-assets-xmb: XMB menu assets'
  63. 'wayland: Wayland support'
  64. )
  65. backup=(etc/retroarch.cfg)
  66. source=(
  67. git+https://github.com/libretro/RetroArch.git#tag=8bcd74bf42f486c37e243a80e29bc214b2b6b205
  68. retroarch-config.patch
  69. libre.patch
  70. )
  71. sha256sums=(
  72. SKIP
  73. 7857cff30c45721b66666828ca9edbb2923817c6c64591be3f58fe019277103e
  74. fc6944ad6bf742c4abf5db69b228a5de8aa5a909a89d227844b90b8d8b817245
  75. )
  76. pkgver() {
  77. cd RetroArch
  78. git describe --tags | sed 's/^v//'
  79. }
  80. prepare() {
  81. cd RetroArch
  82. patch -Np1 -i ../retroarch-config.patch
  83. patch -Np1 -i ${srcdir}/libre.patch
  84. }
  85. build() {
  86. cd RetroArch
  87. ./configure \
  88. --prefix=/usr \
  89. --disable-builtinflac \
  90. --disable-builtinmbedtls \
  91. --disable-builtinminiupnpc \
  92. --disable-builtinzlib \
  93. --disable-cg \
  94. --disable-jack \
  95. --disable-oss \
  96. --disable-sdl \
  97. --enable-dbus
  98. make
  99. make -C libretro-common/audio/dsp_filters
  100. make -C gfx/video_filters
  101. }
  102. package() {
  103. cd RetroArch
  104. make DESTDIR="${pkgdir}" install
  105. install -Dm 644 libretro-common/audio/dsp_filters/*.{dsp,so} -t "${pkgdir}"/usr/lib/retroarch/filters/audio/
  106. install -Dm 644 gfx/video_filters/*.{filt,so} -t "${pkgdir}"/usr/lib/retroarch/filters/video/
  107. }
  108. # vim: ts=2 sw=2 et: