PKGBUILD 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Maintainer:
  2. pkgname=gettext
  3. pkgver=0.19.8.1
  4. pkgrel=2
  5. pkgdesc="GNU internationalization library"
  6. url="https://www.gnu.org/software/gettext/"
  7. arch=(x86_64 ppc64le)
  8. license=(GPL)
  9. groups=(base base-devel)
  10. depends=(gcc-libs acl sh glib2 libunistring libcroco)
  11. makedepends=(gettext emacs git)
  12. optdepends=('git: for autopoint infrastructure updates')
  13. options=(!docs)
  14. source=(https://ftp.gnu.org/pub/gnu/gettext/$pkgname-$pkgver.tar.gz{,.sig}
  15. gettext-0.19.8-its-segfault.patch)
  16. sha256sums=('ff942af0e438ced4a8b0ea4b0b6e0d6d657157c5e2364de57baa279c1c125c43'
  17. 'SKIP'
  18. '0e3b19ea94e956a6a484ca4c4ecea32a01a83f10a413e586183de464c51f158d')
  19. validpgpkeys=('462225C3B46F34879FC8496CD605848ED7E69871') # Daiki Ueno
  20. prepare() {
  21. cd $pkgname-$pkgver
  22. patch -Np1 -i ../gettext-0.19.8-its-segfault.patch
  23. }
  24. build() {
  25. cd $pkgname-$pkgver
  26. ./configure \
  27. --prefix=/usr \
  28. --enable-csharp \
  29. --enable-nls \
  30. --with-xz \
  31. --without-included-gettext
  32. sed -e 's/ -shared / -Wl,-O1,--as-needed\0/g' \
  33. -i gettext-{tools,runtime,runtime/libasprintf}/libtool
  34. make
  35. }
  36. check() {
  37. cd $pkgname-$pkgver
  38. make check
  39. }
  40. package() {
  41. cd $pkgname-$pkgver
  42. make DESTDIR="$pkgdir" install
  43. }