12345678910111213141516171819202122232425262728293031323334353637 |
- # Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
- _pkgname=httpconnectd
- pkgname=$_pkgname-git
- pkgver=20161004
- _gitver='commit=0a9c98e499211e6c291c4188720852bd3823584c'
- pkgdesc="An HTTP server that only implements the CONNECT method"
- url="https://lukeshu.com/git/httpconnectd/"
- license=('WTFPL2')
- backup=('etc/httpconnectd/https.conf')
- provides=($_pkgname)
- conflicts=($_pkgname)
- pkgrel=1
- arch=('any')
- depends=('socat')
- source=("https://repo.parabola.nu/other/~lukeshu/$_pkgname/$pkgname-$pkgver.tar.gz")
- md5sums=('19f0136e2c05e043b5b0b35c15aaf7d9')
- mkdepends=('git')
- mksource=("$pkgname-$pkgver::git://lukeshu.com/$_pkgname.git#$_gitver")
- mkmd5sums=('SKIP')
- build() {
- cd "$srcdir/$pkgname-$pkgver"
- make sysconfdir=/etc prefix=/usr
- }
- package() {
- cd "$srcdir/$pkgname-$pkgver"
- make install sysconfdir=/etc prefix=/usr DESTDIR="$pkgdir"
- }
|