PKGBUILD 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
  2. # Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
  3. # Maintainer: David P. <megver83@parabola.nu>
  4. pkgname=accountsservice
  5. pkgver=0.6.55
  6. pkgrel=1
  7. pkgrel+=.nonsystemd1
  8. pkgdesc="D-Bus interface for user account query and manipulation"
  9. url="https://gitlab.freedesktop.org/accountsservice/accountsservice"
  10. arch=(x86_64)
  11. arch+=(i686 armv7h)
  12. license=(GPL3)
  13. depends=(glib2 polkit elogind)
  14. makedepends=(gtk-doc gobject-introspection git meson docbook-xsl xmlto)
  15. provides+=($pkgname-elogind)
  16. conflicts=(${provides[@]})
  17. replaces=(${provides[@]})
  18. _commit=6d6f7d62fd18fe5a4d4c06cb1455887ca3abdd1d # tags/0.6.55^0
  19. source=("git+https://gitlab.freedesktop.org/accountsservice/accountsservice.git#commit=$_commit")
  20. sha256sums=('SKIP')
  21. pkgver() {
  22. cd $pkgname
  23. git describe --tags | sed 's/-/+/g'
  24. }
  25. prepare() {
  26. cd $pkgname
  27. sed -i '/dbus_conf_dir/s/sysconfdir/datadir/g' meson.build
  28. }
  29. build() {
  30. arch-meson $pkgname build \
  31. -D admin_group=wheel \
  32. -D systemd=false \
  33. -D docbook=true \
  34. -D gtk_doc=true \
  35. -D systemdsystemunitdir=no \
  36. -D elogind=true \
  37. -D user_heuristics=false
  38. ninja -C build
  39. }
  40. check() {
  41. meson test -C build
  42. }
  43. package() {
  44. DESTDIR="$pkgdir" meson install -C build
  45. }
  46. # vim:set ts=2 sw=2 et: