PKGBUILD 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. # Maintainer: David P. <megver83@parabola.nu>
  2. # Maintainer (Arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
  3. # Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
  4. pkgname=lib32-dbus
  5. pkgver=1.12.20
  6. pkgrel=1.1
  7. pkgrel+=.nonsystemd1
  8. pkgdesc="Freedesktop.org message bus system (32-bit)"
  9. url="https://wiki.freedesktop.org/www/Software/dbus/"
  10. arch=(x86_64)
  11. license=(GPL custom)
  12. depends=(lib32-elogind dbus)
  13. makedepends=(lib32-glib2 lib32-expat git autoconf-archive)
  14. source=("git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-$pkgver"
  15. no-fatal-warnings.diff)
  16. sha256sums=('SKIP'
  17. '6958eeec07557b92a28419eb1702331ee2f0a6fd17285e37dfb6130b9fa4cf6e')
  18. validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90') # Simon McVittie <simon.mcvittie@collabora.co.uk>
  19. prepare() {
  20. cd dbus
  21. # Allow us to enable checks without them being fatal
  22. patch -Np1 -i ../no-fatal-warnings.diff
  23. NOCONFIGURE=1 ./autogen.sh
  24. }
  25. build() {
  26. export CC="gcc -m32 -mstackrealign"
  27. export CXX="g++ -m32 -mstackrealign"
  28. export PKG_CONFIG="i686-pc-linux-gnu-pkg-config"
  29. cd dbus
  30. ./configure \
  31. --prefix=/usr \
  32. --sysconfdir=/etc \
  33. --localstatedir=/var \
  34. --libdir=/usr/lib32 \
  35. --libexecdir=/usr/lib/dbus-1.0 \
  36. runstatedir=/run \
  37. --with-console-auth-dir=/run/console/ \
  38. --with-dbus-user=dbus \
  39. --with-system-pid-file=/run/dbus/pid \
  40. --with-system-socket=/run/dbus/system_bus_socket \
  41. --disable-systemd \
  42. --without-systemdsystemunitdir \
  43. --enable-inotify \
  44. --disable-libaudit \
  45. --enable-user-session \
  46. --disable-xml-docs \
  47. --disable-doxygen-docs \
  48. --disable-ducktype-docs \
  49. --disable-static \
  50. --without-x
  51. make
  52. }
  53. check() {
  54. make -C dbus check
  55. }
  56. package() {
  57. provides=(lib32-libdbus libdbus-1.so)
  58. conflicts=(lib32-libdbus)
  59. replaces=(lib32-libdbus)
  60. DESTDIR="$pkgdir" make -C dbus install
  61. rm -r "$pkgdir"/{etc,var}
  62. rm -r "$pkgdir"/usr/{bin,include,lib,share}
  63. install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
  64. }
  65. # vim:set sw=2 et: