PKGBUILD 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100
  1. # Maintainer (arch): Andreas Radke <andyrtr@archlinux.org>
  2. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  3. # Contributor: Márcio Silva <coadde@hyperbola.info>
  4. # Contributor: bill-auger <bill-auger@programmer.net>
  5. # parabola changes and rationale:
  6. # - removed 'libgdata' support (--help) and optdepends
  7. # - FIXME: added 'webkit2gtk' dep; but the arch PKGBUILD does not require it
  8. pkgname=claws-mail
  9. pkgver=4.0.0
  10. pkgrel=3
  11. pkgrel+=.nonprism2
  12. pkgdesc="A GTK+ based e-mail client"
  13. pkgdesc+=", without libgdata support"
  14. arch=('x86_64')
  15. arch+=('armv7h' 'i686')
  16. license=('GPL3')
  17. url="https://www.claws-mail.org"
  18. depends=('gtk3' 'gnutls' 'startup-notification' 'enchant' 'gpgme'
  19. 'libetpan' 'compface' 'libsm' 'dbus-glib')
  20. makedepends=('spamassassin' 'bogofilter' 'networkmanager' 'valgrind'
  21. # dependencies for plugins
  22. 'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'libytnef' 'libical'
  23. 'dillo' 'python' 'gumbo-parser'
  24. # deps to build the docs
  25. 'docbook-utils' 'texlive-formatsextra')
  26. makedepends=(${makedepends[@]/libgdata/})
  27. makedepends+=('webkit2gtk') # FIXME:
  28. optdepends=('python: needed for some tools'
  29. 'perl: needed for some tools and perl plugin'
  30. 'spamassassin: adds support for spamfiltering'
  31. 'bogofilter: adds support for spamfiltering'
  32. 'libnotify: for notification plugin'
  33. 'libcanberra: for notification plugin'
  34. 'dbus: for notification plugin'
  35. 'libxml2: for rssyl plugins'
  36. 'curl: for vcalendar, rssyl and spamreport plugins'
  37. 'libarchive: for archive plugin and various other plugins'
  38. 'libytnef: for tnef_parse plugin'
  39. 'poppler-glib: for pdf viewer plugin'
  40. 'ghostscript: for pdf viewer plugin'
  41. 'libical: for vcalendar plugin'
  42. 'dillo: for dillo html viewer plugin'
  43. 'webkit2gtk: for fancy webkit html viewer plugin'
  44. 'gumbo-parser: for litehtml plugin')
  45. provides=('claws')
  46. install=$pkgname.install
  47. source=(https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
  48. 0001_move_OAuth2_to_last_place_in_auto_auth_selection.diff
  49. 0002_Fancy_crashes_when_opening_an_email.diff
  50. bash_completion)
  51. sha256sums=('4af2bd26a5d91eacb2a9c09f67a6a46c2222b40817c1f525dc050bdc7b0ee475'
  52. 'SKIP'
  53. 'ffd5dfe8929a86667218512095a794263a2ae56fae4add83d3ad987f94e7f786'
  54. 'f56256a9535958063b966ab52abdf787422ff71ed2a5c41b3d9fea8716defe85'
  55. '3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb')
  56. validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
  57. prepare() {
  58. cd "${pkgname}"-${pkgver}
  59. # upstream fixes
  60. patch -Np1 -i ../0001_move_OAuth2_to_last_place_in_auto_auth_selection.diff
  61. patch -Np1 -i ../0002_Fancy_crashes_when_opening_an_email.diff
  62. }
  63. build() {
  64. cd "${pkgname}"-${pkgver}
  65. ./configure --prefix=/usr --disable-static \
  66. --enable-enchant \
  67. --enable-gnutls \
  68. --enable-ldap \
  69. --enable-crash-dialog \
  70. --disable-gdata-plugin \
  71. --enable-pgpmime-plugin \
  72. --enable-spamassassin-plugin \
  73. --enable-bogofilter-plugin \
  74. --enable-fancy-plugin \
  75. --enable-manual
  76. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  77. make
  78. }
  79. package() {
  80. cd "${pkgname}"-${pkgver}
  81. make DESTDIR="${pkgdir}" install
  82. install -Dm 644 "$srcdir"/bash_completion "${pkgdir}"/usr/share/bash-completion/completions/claws-mail
  83. # install extra tools
  84. cd tools
  85. install -m755 -d "${pkgdir}"/usr/lib/claws-mail/tools
  86. for files in *.pl *.py *.sh *.conf tb2claws-mail update-po uudec uuooffice README; do
  87. cp -arv $files "${pkgdir}"/usr/lib/claws-mail/tools/
  88. done
  89. }