PKGBUILD 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
  2. # Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
  3. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  4. # Contributor: Isaac David <isacdaavid@at@isacdaavid.info>
  5. # Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
  6. # parabola changes and rationale:
  7. # - removed geoclue2 support
  8. # - add libmm-glib as dependency (implicit in upstream)
  9. pkgname=gnome-settings-daemon
  10. pkgver=3.34.1+1+ge1fc4599
  11. pkgrel=1
  12. pkgrel+=.nonprism1
  13. pkgdesc="GNOME Settings Daemon, without geoclue2 support"
  14. url="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
  15. arch=(x86_64)
  16. arch+=(i686 armv7h)
  17. license=(GPL)
  18. depends=(dconf gnome-desktop gsettings-desktop-schemas libcanberra-pulse libnotify systemd-libs
  19. libwacom pulseaudio pulseaudio-alsa upower librsvg libgweather geocode-glib nss
  20. libgudev gtk3-print-backends libnm gcr libmm-glib)
  21. makedepends=(xf86-input-wacom libxslt docbook-xsl python git meson)
  22. checkdepends=(python-gobject python-dbusmock)
  23. groups=(gnome)
  24. _commit=e1fc4599764c9b10e086317164267c78f9338883 # gnome-3-34
  25. source=("git+https://gitlab.gnome.org/GNOME/gnome-settings-daemon.git#commit=$_commit"
  26. "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
  27. nonprism.patch)
  28. sha256sums=('SKIP'
  29. 'SKIP'
  30. '6619205eb1e4d87caeb8e1673d6c80acf4d30f15ae91c5f6cb728a2e5674bf65')
  31. pkgver() {
  32. cd $pkgname
  33. git describe --tags | sed 's/^GNOME_SETTINGS_DAEMON_//;s/_/./g;s/-/+/g'
  34. }
  35. prepare() {
  36. cd $pkgname
  37. git submodule init
  38. git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
  39. git submodule update
  40. patch -p1 -i $srcdir/nonprism.patch
  41. }
  42. build() {
  43. arch-meson $pkgname build
  44. ninja -C build
  45. }
  46. check() {
  47. meson test -C build
  48. }
  49. package() {
  50. DESTDIR="$pkgdir" meson install -C build
  51. }