12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182 |
- # Maintainer (arch): Andreas Radke <andyrtr@archlinux.org>
- # Contributor: Andreas Grapentin <andreas@grapentin.org>
- # Contributor: Márcio Silva <coadde@hyperbola.info>
- # Contributor: bill-auger <bill-auger@programmer.net>
- # parabola changes and rationale:
- # - removed libgdata support (--help)
- pkgname=claws-mail
- pkgver=3.17.8
- pkgrel=1
- pkgrel+=.nonprism1
- pkgdesc="A GTK+ based e-mail client."
- pkgdesc="${pkgdesc//./}, without libgdata support"
- arch=('x86_64')
- arch+=('armv7h' 'i686')
- license=('GPL3')
- url="https://www.claws-mail.org"
- depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme'
- 'libetpan' 'compface' 'libsm' 'dbus-glib')
- makedepends=('spamassassin' 'bogofilter' 'networkmanager' 'valgrind'
- # dependencies for plugins
- 'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'libytnef' 'libical'
- 'dillo' 'python' 'gumbo-parser'
- # deps to build the docs
- 'docbook-utils' 'texlive-formatsextra')
- makedepends=(${makedepends[@]/libgdata/})
- optdepends=('python: needed for some tools'
- 'perl: needed for some tools and perl plugin'
- 'spamassassin: adds support for spamfiltering'
- 'bogofilter: adds support for spamfiltering'
- 'libnotify: for notification plugin'
- 'libcanberra: for notification plugin'
- 'dbus: for notification plugin'
- 'libxml2: for gtkhtml2_viewer and rssyl plugins'
- 'curl: for gtkhtml2_viewer, vcalendar, rssyl and spamreport plugins'
- 'libarchive: for archive plugin and various other plugins'
- 'libytnef: for tnef_parse plugin'
- 'poppler-glib: for pdf viewer plugin'
- 'ghostscript: for pdf viewer plugin'
- 'libical: for vcalendar plugin'
- 'dillo: for html viewer plugin'
- 'gumbo-parser: for litehtml plugin')
- provides=('claws')
- source=(https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
- bash_completion)
- sha256sums=('cdb7b2814995d6f4a9c3b1f0bc1467ed5c3cf2a5e0da1730aaa25a8accafddaf'
- 'SKIP'
- '3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb')
- validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
- build() {
- cd "${pkgname}"-${pkgver}
- ./configure --prefix=/usr --disable-static \
- --enable-enchant \
- --enable-gnutls \
- --enable-ldap \
- --enable-crash-dialog \
- --disable-gdata-plugin \
- --enable-pgpmime-plugin \
- --enable-spamassassin-plugin \
- --enable-bogofilter-plugin
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
- }
- package() {
- cd "${pkgname}"-${pkgver}
- make DESTDIR="${pkgdir}" install
- install -Dm 644 "$srcdir"/bash_completion "${pkgdir}"/usr/share/bash-completion/completions/claws-mail
- # install extra tools
- cd tools
- install -m755 -d "${pkgdir}"/usr/lib/claws-mail/tools
- for files in *.pl *.py *.sh *.conf tb2claws-mail update-po uudec uuooffice README; do
- cp -arv $files "${pkgdir}"/usr/lib/claws-mail/tools/
- done
- }
|