PKGBUILD 3.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. # Maintainer (arch): Andreas Radke <andyrtr@archlinux.org>
  2. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  3. # Contributor: Márcio Silva <coadde@hyperbola.info>
  4. # Contributor: bill-auger <bill-auger@programmer.net>
  5. # parabola changes and rationale:
  6. # - removed libgdata support (--help)
  7. pkgname=claws-mail
  8. pkgver=3.17.8
  9. pkgrel=1
  10. pkgrel+=.nonprism1
  11. pkgdesc="A GTK+ based e-mail client."
  12. pkgdesc="${pkgdesc//./}, without libgdata support"
  13. arch=('x86_64')
  14. arch+=('armv7h' 'i686')
  15. license=('GPL3')
  16. url="https://www.claws-mail.org"
  17. depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme'
  18. 'libetpan' 'compface' 'libsm' 'dbus-glib')
  19. makedepends=('spamassassin' 'bogofilter' 'networkmanager' 'valgrind'
  20. # dependencies for plugins
  21. 'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'libytnef' 'libical'
  22. 'dillo' 'python' 'gumbo-parser'
  23. # deps to build the docs
  24. 'docbook-utils' 'texlive-formatsextra')
  25. makedepends=(${makedepends[@]/libgdata/})
  26. optdepends=('python: needed for some tools'
  27. 'perl: needed for some tools and perl plugin'
  28. 'spamassassin: adds support for spamfiltering'
  29. 'bogofilter: adds support for spamfiltering'
  30. 'libnotify: for notification plugin'
  31. 'libcanberra: for notification plugin'
  32. 'dbus: for notification plugin'
  33. 'libxml2: for gtkhtml2_viewer and rssyl plugins'
  34. 'curl: for gtkhtml2_viewer, vcalendar, rssyl and spamreport plugins'
  35. 'libarchive: for archive plugin and various other plugins'
  36. 'libytnef: for tnef_parse plugin'
  37. 'poppler-glib: for pdf viewer plugin'
  38. 'ghostscript: for pdf viewer plugin'
  39. 'libical: for vcalendar plugin'
  40. 'dillo: for html viewer plugin'
  41. 'gumbo-parser: for litehtml plugin')
  42. provides=('claws')
  43. source=(https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
  44. bash_completion)
  45. sha256sums=('cdb7b2814995d6f4a9c3b1f0bc1467ed5c3cf2a5e0da1730aaa25a8accafddaf'
  46. 'SKIP'
  47. '3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb')
  48. validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
  49. build() {
  50. cd "${pkgname}"-${pkgver}
  51. ./configure --prefix=/usr --disable-static \
  52. --enable-enchant \
  53. --enable-gnutls \
  54. --enable-ldap \
  55. --enable-crash-dialog \
  56. --disable-gdata-plugin \
  57. --enable-pgpmime-plugin \
  58. --enable-spamassassin-plugin \
  59. --enable-bogofilter-plugin
  60. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  61. make
  62. }
  63. package() {
  64. cd "${pkgname}"-${pkgver}
  65. make DESTDIR="${pkgdir}" install
  66. install -Dm 644 "$srcdir"/bash_completion "${pkgdir}"/usr/share/bash-completion/completions/claws-mail
  67. # install extra tools
  68. cd tools
  69. install -m755 -d "${pkgdir}"/usr/lib/claws-mail/tools
  70. for files in *.pl *.py *.sh *.conf tb2claws-mail update-po uudec uuooffice README; do
  71. cp -arv $files "${pkgdir}"/usr/lib/claws-mail/tools/
  72. done
  73. }