PKGBUILD 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. # Maintainer (Arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
  2. # Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
  3. # Contributor (Arch): Allan McRae <allan@archlinux.org>
  4. # Contributor (Arch): Alessio 'mOLOk' Bolognino <themolok@gmail.com>
  5. # Contributor (Arch): shamrok <szamrok@gmail.com>
  6. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  7. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  8. # Contributor: André Silva <emulatorman@hyperbola.info>
  9. # parabola changes and rationale:
  10. # - removed smtube support
  11. pkgname=smplayer
  12. pkgver=21.1.0
  13. pkgrel=1
  14. pkgrel+=.parabola1
  15. pkgdesc='Media player with built-in codecs that can play virtually all video and audio formats'
  16. pkgdesc+=', without nonfree smtube support'
  17. url='https://www.smplayer.info/'
  18. arch=('x86_64')
  19. arch+=('i686' 'armv7h')
  20. license=('GPL')
  21. depends=('glibc' 'qt5-script' 'qt5-base' 'mpv' 'libx11' 'zlib' 'gcc-libs' 'hicolor-icon-theme')
  22. makedepends=('qt5-tools')
  23. optdepends=('smplayer-themes: icon themes collection'
  24. 'smplayer-skins: skin themes collection'
  25. 'youtube-dl: youtube videos and streaming'
  26. 'mplayer: alternative multimedia engine')
  27. source=(https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.bz2
  28. libre.patch)
  29. sha512sums=('94030ddba63355403f14ce70a3b7719eaa0b006017148039bcc691159c33bbb6c8a947bff10dab9fecc0daa7106ac1b9f3ac7d7ea4263d622240636743c90553'
  30. 'cbe4e873596abb175721ae737dc078e78074c50f4e96165a26849348138304fdbbef3a68655fa6f1be79dcd5d55c587c150e97650d76b832ab2a0dbaffd92ea4')
  31. b2sums=('593ceae2ceeeea6a9689c8e92a1a15fcdd7e2e3f04a6982f0fc36864ced157ff4cb59a26cc9941931aef8e31eef1d580fd606cd2ae396ba1e998233a1e30e74d'
  32. '9ba5864153e95a7192631945b8d95ec86f5f4817a57fcc8dbb0b7701eceabe8721d9858083ab91993f6eb8c7b2142057383d5d682b663b97d0df1304dabdc141')
  33. prepare() {
  34. cd ${pkgname}-${pkgver}
  35. # disable SMTube support
  36. patch -p1 -i $srcdir/libre.patch
  37. # fix GNU/Linux name
  38. sed -i 's|Linux|GNU/Linux|' src/smplayer.cpp
  39. # make build reproducible, we compress ourselves
  40. sed '/gzip -9/d' -i Makefile
  41. }
  42. build() {
  43. cd ${pkgname}-${pkgver}
  44. export CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}"
  45. make PREFIX=/usr \
  46. DOC_PATH="\\\"/usr/share/doc/smplayer\\\"" \
  47. QMAKE_OPTS=DEFINES+=NO_DEBUG_ON_CONSOLE \
  48. CFLAGS_EXTRA="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}"
  49. }
  50. package() {
  51. cd ${pkgname}-${pkgver}
  52. make DOC_PATH=/usr/share/doc/smplayer \
  53. DESTDIR="${pkgdir}" PREFIX=/usr -j1 install
  54. }
  55. # vim: ts=2 sw=2 et: