PKGBUILD 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Maintainer: not me :)
  2. # Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
  3. pkgname=intellij-idea-community-edition
  4. pkgver=2018.1.4
  5. _pkgver=181.5087.20
  6. pkgrel=1.parabola1
  7. epoch=2
  8. pkgdesc="IDE for Java, Groovy and other programming languages with advanced refactoring features"
  9. arch=('any')
  10. url="https://www.jetbrains.com/idea/"
  11. license=('Apache')
  12. backup=('usr/share/intellijidea-ce/bin/idea.vmoptions'
  13. 'usr/share/intellijidea-ce/bin/idea64.vmoptions')
  14. depends=('java-environment=8' 'giflib' 'libxtst' 'libxft' 'ttf-font'
  15. 'coreutils' 'grep' 'which')
  16. conflicts=('intellij-idea-libs')
  17. replaces=('intellij-idea-libs')
  18. install=idea.install
  19. source=(https://github.com/JetBrains/intellij-community/archive/idea/${_pkgver%.*}.tar.gz
  20. idea.desktop
  21. idea.sh)
  22. sha256sums=('fa31113e3676e8d036e35e287f9c55f3b1c50413898a8e61f84e605c3808e5cc'
  23. 'bd37ad47c926941108f624cbe5adbd7fe91d198b15aca63d8a0c0da14c7a76a6'
  24. '0e5d6a47b5ae464e9f562110ccc798f55055943e425e0621c0275f72615fdb1d')
  25. build()
  26. {
  27. cd "intellij-community-idea-${_pkgver%.*}"
  28. ant
  29. }
  30. package()
  31. {
  32. # TODO:
  33. # as is, this fails to build so this function has not been reached yet
  34. # so this function may need some tweaking
  35. # it is from the arch package that did not have a build() function
  36. # but merely packaged downloaded binaries
  37. install -d -m755 "$pkgdir/"usr/share
  38. cp -a "idea-IC-$_pkgver" "$pkgdir"/usr/share/intellijidea-ce
  39. # make sure that all files are owned by root
  40. chown -R root:root "$pkgdir/usr/share"
  41. install -d -m755 "$pkgdir"/usr/bin
  42. install -D -m755 "$srcdir"/idea.sh "$pkgdir"/usr/bin/idea.sh
  43. install -D -m644 "$srcdir"/idea.desktop "$pkgdir"/usr/share/applications/idea.desktop
  44. install -D -m644 "$pkgdir"/usr/share/intellijidea-ce/bin/idea.png \
  45. "$pkgdir"/usr/share/pixmaps/idea.png
  46. # workaround FS#40934
  47. sed -i 's|lcd|on|' "$pkgdir"/usr/share/intellijidea-ce/bin/*.vmoptions
  48. }