PKGBUILD 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright (C) 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
  2. # This program is free software: you can redistribute it and/or modify
  3. # it under the terms of the CC0 1.0 License.
  4. # Maintainer: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
  5. pkgname=gnutoo-scripts
  6. pkgver=0.0.1
  7. pkgrel=2
  8. pkgdesc="Various scripts that don't fit elsewhere"
  9. arch=('any')
  10. url='https://git.sr.ht/~gnutoo/scripts'
  11. license=('GPL3')
  12. depends=('hdparm' # storage.sh
  13. 'openssh' # ssh-gen.sh
  14. 'python' # gen-pts-guix-test.py
  15. 'smartmontools') # storage.sh
  16. makedepends=('autoconf'
  17. 'automake'
  18. 'git'
  19. 'systemd')
  20. optdepends=('postgresql-libs: for adding batteries to a (GNUtoo specific) database in batt.sh'
  21. 'systemd: for automatic logging support in batt.sh')
  22. source=("git+https://git.sr.ht/~gnutoo/scripts#commit=v${pkgver}")
  23. sha512sums=('SKIP')
  24. build(){
  25. cd scripts
  26. ./autogen.sh
  27. ./configure --prefix=/usr --with-systemd
  28. make
  29. }
  30. package(){
  31. cd scripts
  32. make install DESTDIR="${pkgdir}"
  33. }