PKGBUILD 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101
  1. # Maintainer (arch): Fabian Bornschein <fabiscafe-at-mailbox-dot-org>
  2. # Maintainer (arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
  3. # Contributor: André Silva <emulatorman@hyperbola.info>
  4. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  5. # Contributor: Isaac David <isacdaavid@at@isacdaavid.info>
  6. # Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
  7. # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
  8. # parabola changes and rationale:
  9. # - removed geoclue support
  10. pkgname=gnome-settings-daemon
  11. pkgver=45.0
  12. pkgrel=1
  13. pkgrel+=.nonprism1
  14. pkgdesc="GNOME Settings Daemon"
  15. pkgdesc+=", without geoclue support"
  16. url="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
  17. arch=(x86_64)
  18. arch+=(armv7h i686)
  19. license=(GPL)
  20. depends=(
  21. dconf
  22. gcr-4
  23. geoclue
  24. geocode-glib-2
  25. gnome-desktop
  26. gsettings-desktop-schemas
  27. gtk3
  28. libcanberra-pulse
  29. libgudev
  30. libgweather-4
  31. libnm
  32. libnotify
  33. librsvg
  34. libwacom
  35. nss
  36. pulseaudio
  37. pulseaudio-alsa
  38. systemd
  39. upower
  40. )
  41. depends=( ${depends[*]/geoclue/} ) # privacy
  42. makedepends=(
  43. docbook-xsl
  44. git
  45. libxslt
  46. meson
  47. python
  48. usbguard
  49. )
  50. makedepends+=(libmm-glib) # gnome-settings-daemon/meson.build:220:16: ERROR: Dependency "mm-glib" not found, tried pkgconfig
  51. checkdepends=(
  52. python-dbusmock
  53. python-gobject
  54. )
  55. optdepends=('usbguard: USB protection support')
  56. groups=(gnome)
  57. backup=(etc/xdg/Xwayland-session.d/00-xrdb)
  58. _commit=ed2173a812a820d3e7aaa8107e554f9e6068684f # tags/45.0^0
  59. source=(
  60. "git+https://gitlab.gnome.org/GNOME/gnome-settings-daemon.git#commit=$_commit"
  61. "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
  62. )
  63. source+=(nonprism.patch)
  64. b2sums=('SKIP'
  65. 'SKIP')
  66. b2sums+=('5bccb162d6fa29940b77ca50fe64190522029424ded00af7e121748726a9b5a730bc637730f0322af45da0ce883af97bc31cd760e88602a0f1ed582889fa59c2')
  67. pkgver() {
  68. cd $pkgname
  69. git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
  70. }
  71. prepare() {
  72. cd $pkgname
  73. git submodule init
  74. git submodule set-url subprojects/gvc "$srcdir/libgnome-volume-control"
  75. git -c protocol.file.allow=always submodule update
  76. echo "applying nonprism.patch"
  77. patch -p1 -i $srcdir/nonprism.patch
  78. }
  79. build() {
  80. arch-meson $pkgname build
  81. meson compile -C build
  82. }
  83. check() {
  84. meson test -C build --print-errorlogs
  85. }
  86. package() {
  87. meson install -C build --destdir "$pkgdir"
  88. }