PKGBUILD 904 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Maintainer (aur): Timothy Redaelli <timothy.redaelli@gmail.com>
  2. # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
  3. # parabola changes and rationale:
  4. # no changes.
  5. pkgname=ucommon
  6. pkgver=7.0.0
  7. pkgrel=1
  8. pkgdesc="A light-weight C++ library to facilitate using C++ design patterns"
  9. arch=('i686' 'x86_64' 'armv7h')
  10. url="http://www.gnutelephony.org/index.php/GNU_uCommon_C++"
  11. license=('LGPL3')
  12. depends=('gnutls')
  13. source=("http://ftp.gnu.org/pub/gnu/commoncpp/$pkgname-$pkgver.tar.gz"{,.sig})
  14. md5sums=('90468af8f6692f0b6576189927414a39'
  15. 'SKIP')
  16. validpgpkeys=('5CF995AAD5CC1E4079F76C38B1732A9CB37C87BA')
  17. build() {
  18. cd ${pkgname}-${pkgver}
  19. ./configure --prefix=/usr --with-sslstack=gnu --enable-socks --enable-stdcpp --enable-atomics --with-pkg-config
  20. make
  21. }
  22. check() {
  23. cd ${pkgname}-${pkgver}
  24. make check
  25. }
  26. package() {
  27. cd ${pkgname}-${pkgver}
  28. make DESTDIR="${pkgdir}" install
  29. }