12345678910111213141516171819202122232425262728293031 |
- # Maintainer (aur): Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
- # parabola changes and rationale:
- # - Added armv7h
- pkgname=selinux-python
- pkgver=3.2
- pkgrel=1
- pkgdesc="SELinux python tools and libraries"
- groups=('selinux')
- arch=('i686' 'x86_64')
- arch+=('armv7h')
- url='https://github.com/SELinuxProject/selinux/wiki'
- license=('GPL2')
- depends=('python' 'python-audit' 'python-ipy' 'libsemanage>=3.2' 'setools>=4.4.0')
- conflicts=('sepolgen<2.7' 'policycoreutils<2.7')
- provides=("sepolgen=${pkgver}-${pkgrel}")
- source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
- sha256sums=('770855ea8120ef23007fdb9db94b1ed6e8cd77917b584ed8877bbee9c16e74fb')
- build() {
- cd "${pkgbase}-${pkgver}"
- make PYTHON=/usr/bin/python3
- }
- package() {
- cd "${pkgbase}-${pkgver}"
- make PYTHON=/usr/bin/python3 DESTDIR="${pkgdir}" SBINDIR=/usr/bin install
- /usr/bin/python3 -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'import site; print(site.getsitepackages()[0])')"
- }
|