PKGBUILD 1016 B

12345678910111213141516171819202122232425262728293031
  1. # Maintainer (aur): Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
  2. # parabola changes and rationale:
  3. # - Added armv7h
  4. pkgname=selinux-python
  5. pkgver=3.2
  6. pkgrel=1
  7. pkgdesc="SELinux python tools and libraries"
  8. groups=('selinux')
  9. arch=('i686' 'x86_64')
  10. arch+=('armv7h')
  11. url='https://github.com/SELinuxProject/selinux/wiki'
  12. license=('GPL2')
  13. depends=('python' 'python-audit' 'python-ipy' 'libsemanage>=3.2' 'setools>=4.4.0')
  14. conflicts=('sepolgen<2.7' 'policycoreutils<2.7')
  15. provides=("sepolgen=${pkgver}-${pkgrel}")
  16. source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
  17. sha256sums=('770855ea8120ef23007fdb9db94b1ed6e8cd77917b584ed8877bbee9c16e74fb')
  18. build() {
  19. cd "${pkgbase}-${pkgver}"
  20. make PYTHON=/usr/bin/python3
  21. }
  22. package() {
  23. cd "${pkgbase}-${pkgver}"
  24. make PYTHON=/usr/bin/python3 DESTDIR="${pkgdir}" SBINDIR=/usr/bin install
  25. /usr/bin/python3 -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'import site; print(site.getsitepackages()[0])')"
  26. }