PKGBUILD 1.1 KB

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright (C) 2019 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
  2. # This program is free software: you can redistribute it and/or modify
  3. # it under the terms of the CC0 1.0 License.
  4. # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
  5. pkgname=qdl
  6. pkgver=1.0
  7. pkgrel=5
  8. pkgdesc="Tool to communicate with Qualcomm System On a Chip bootroms to install or execute code"
  9. arch=('armv7h' 'i686' 'x86_64')
  10. url='https://github.com/andersson/qdl'
  11. license=('BSD3')
  12. depends=('libxml2')
  13. source=("https://github.com/andersson/${pkgname}/archive/v${pkgver}.tar.gz")
  14. sha512sums=('561b6ffaf26d063f107a0769b41d0ed02f1f6c4656b6284e653e8baf69b2f34d5f6051e54bb45ab55c028bb8bfa9b4e5218b796dbdb7ab7686576168b1b11d77')
  15. build(){
  16. cd "${srcdir}/${pkgname}-${pkgver}"
  17. make
  18. }
  19. package(){
  20. cd "${srcdir}/${pkgname}-${pkgver}"
  21. make prefix="/usr" DESTDIR="${pkgdir}" install
  22. # Package license
  23. install -d "${pkgdir}/usr/share/licenses/${pkgname}/"
  24. install LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
  25. # Package documentation
  26. install -d "${pkgdir}/usr/share/doc/${pkgname}/"
  27. install README "${pkgdir}/usr/share/doc/${pkgname}/"
  28. }