PKGBUILD 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Maintainer (arch): Antonio Rojas <nqn1976 @ gmail.com>
  2. # Contributor: Alexander Rødseth <rodseth@gmail.com>
  3. # Contributor: Angel Velasquez <angvp@archlinux.org>
  4. # Contributor: Hugo Doria <hugo@archlinux.org>
  5. # Contributor: Andrew Wright <andreww@photism.org>
  6. # Maintainer: Guest One <theguestone at gmail dot com>
  7. pkgname=nicotine
  8. pkgver=1.2.16
  9. pkgrel=7
  10. pkgdesc='Soulseek music-sharing client, written in python'
  11. arch=('x86_64' 'i686')
  12. url='http://sourceforge.net/projects/nicotine-plus/'
  13. license=('GPL')
  14. depends=('pygtk' 'mutagen')
  15. makedepends=('setconf')
  16. optdepends=('python2-geoip: to enable Geographical blocker' 'python2-sexy: spell checking support' 'miniupnpc-python2: UPNP support')
  17. source=("http://downloads.sourceforge.net/project/nicotine-plus/nicotine-plus/${pkgver}/${pkgname}+-${pkgver}.tar.bz2")
  18. sha256sums=('71e5b33e273daaf072dbf63839536c14d7ead9d149323d50eee09f7429e34c1d')
  19. prepare() {
  20. cd "$srcdir/${pkgname}+-$pkgver"
  21. # Fix for FS#22476
  22. setconf files/nicotine.desktop Icon nicotine-plus-32px
  23. # Python fix
  24. sed -i -e 's|/usr/bin/env python|/usr/bin/env python2|' \
  25. -e 's|/usr/bin/python|/usr/bin/python2|' pynicotine/{,gtkgui/}*.py
  26. }
  27. build() {
  28. cd "$srcdir/${pkgname}+-$pkgver/trayicon"
  29. python2 autogen.py
  30. make
  31. }
  32. package() {
  33. cd "$srcdir/${pkgname}+-$pkgver"
  34. python2 setup.py install --root="$pkgdir"
  35. cd trayicon
  36. make DESTDIR="$pkgdir" install
  37. ln -s nicotine.py "$pkgdir/usr/bin/nicotine"
  38. }
  39. # vim:set ts=2 sw=2 et: