PKGBUILD 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. # Contributor: David Virgilio <drvirgilio@gmail.com>
  2. # Contributor: David Zaragoza <david@zaragoza.com.ve>
  3. # Contributor: Clément Démoulins <clement@archivel.fr>
  4. # Maintainer (aur): Raphaël Doursenaud <rdoursenaud@free.fr>
  5. pkgname=frescobaldi
  6. pkgver=3.1.2
  7. pkgrel=2
  8. pkgdesc="A LilyPond sheet music text editor."
  9. arch=('any')
  10. url="http://www.frescobaldi.org/"
  11. license=('GPL')
  12. depends=(
  13. 'hyphen'
  14. 'poppler'
  15. 'python>=3.3'
  16. 'python-ly>=0.9.5'
  17. 'python-poppler-qt5'
  18. 'python-pyqt5>=5.9'
  19. 'python-sip'
  20. 'qt5-base>=5.9'
  21. 'qt5-svg>=5.9'
  22. 'qt5-webkit>=5.9'
  23. 'hicolor-icon-theme'
  24. 'tango-icon-theme'
  25. )
  26. optdepends=(
  27. 'lilypond: Music engraving (recommended)'
  28. # python-portmidi is currently a python2 package
  29. # 'python-portmidi: MIDI playback (default engine)'
  30. 'python-pygame: MIDI playback (alternate engine)'
  31. 'portmidi: MIDI playback (fallback engine)'
  32. 'hyphen-de: German hyphenation rules'
  33. 'hyphen-en: English hyphenation rules'
  34. 'hyphen-es: Spanish hyphenation rules'
  35. 'hyphen-fr: French hyphenation rules'
  36. 'hyphen-hu: Hungarian hyphenation rules'
  37. 'hyphen-it: Italian hyphenation rules'
  38. 'hyphen-nl: Dutch hyphenation rules'
  39. 'hyphen-ro: Romanian hyphenation rules'
  40. 'python-pycups: Printing to a local CUPS server'
  41. )
  42. source=(https://github.com/frescobaldi/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
  43. sha256sums=('5c2cffb8282cd9faef1585808bd800d1eb3c0db4cc464a61ce8576dbf7ef9b20')
  44. prepare() {
  45. cd "${srcdir}/${pkgname}-${pkgver}"
  46. # Provided by tango-icon-theme
  47. rm -rf "frescobaldi_app/icons/Tango"
  48. # Provided by hyphen-*
  49. rm -f frescobaldi_app/hyphdicts/hyph_*.dic
  50. rm -f frescobaldi_app/hyphdicts/README*
  51. # error in setup.cfg: command 'install' has no such option 'single_version_externally_managed'
  52. sed -i 's|single-version-externally-managed.*||' setup.cfg
  53. }
  54. package() {
  55. cd "${srcdir}/${pkgname}-${pkgver}"
  56. python setup.py install --root="${pkgdir}/" --optimize=1
  57. }