PKGBUILD 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. # Maintainer (arch): Phillip Smith <pkgbuild@phs.id.au>
  2. # http://github.com/fukawi2/aur-packages
  3. # Contributor: Nathan Owe <ndowens04 at gmail>
  4. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  5. ### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
  6. ### Please ask support questions about this software in one of:
  7. ### 1) The AUR comments; OR
  8. ### 2) Upstream forums/maillist etc; OR
  9. ### 3) The ArchLinux forums
  10. ### I do not always know enough about the software itself, or don't have the
  11. ### time to promptly respond to direct emails.
  12. ### If you have found a problem with the package/PKGBUILD (as opposed to
  13. ### the software) then please do email me or post an AUR comment.
  14. pkgname=freeipmi
  15. pkgver=1.5.1
  16. pkgrel=1
  17. pkgdesc="sensor monitoring, system event monitoring, power control, and serial-over-LAN (SOL)"
  18. arch=('i686' 'x86_64')
  19. url="http://www.gnu.org/software/freeipmi/"
  20. license=('GPL')
  21. depends=('libgcrypt')
  22. options=('!libtool')
  23. source=("http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
  24. 'bmc-watchdog.service'
  25. 'ipmidetectd.service'
  26. 'ipmiseld.service')
  27. md5sums=('19794bf257820dd2ef33520f75d51d35'
  28. '8993098bae8cc6b134a330105373d258'
  29. 'bb8bd4f7e5dddbbb15e309c3f1090551'
  30. 'd8b0658fb8037bf4c09b9179223e4972')
  31. build() {
  32. cd $srcdir/$pkgname-$pkgver
  33. ./configure \
  34. --prefix=/usr \
  35. --sbindir=/usr/bin \
  36. --mandir=/usr/share/man \
  37. --sysconfdir=/etc \
  38. --localstatedir=/var/lib \
  39. --infodir=/usr/share/info
  40. make
  41. }
  42. package() {
  43. cd $srcdir/$pkgname-$pkgver
  44. make DESTDIR=$pkgdir/ install
  45. rm -Rf $pkgdir/usr/share/info/dir
  46. # Move init scripts and config to Arch paths
  47. mv $pkgdir/etc/sysconfig $pkgdir/etc/conf.d
  48. # We need system units, not rc scripts
  49. rm -Rf "$pkgdir"/etc/init.d/
  50. for svcname in bmc-watchdog ipmidetectd ipmiseld ; do
  51. install -Dm644 "$srcdir"/${svcname}.service \
  52. "$pkgdir"/usr/lib/systemd/system/${svcname}.service
  53. done
  54. }
  55. # vim:set ts=2 sw=2 et: