PKGBUILD 3.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. # Maintainer (arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
  2. # Contributor: Jan de Groot <jgc@archlinux.org>
  3. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  4. # Contributor: Márcio Silva <coadde@hyperbola.info>
  5. # Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
  6. # Contributor: Freemor <freemor@freemor.ca>
  7. # Contributor: bill-auger <bill-auger@programmer.net>
  8. # parabola changes and rationale:
  9. # - removed libgweather support
  10. # - removed libgdata support
  11. # - removed google support
  12. # - pinned to 'icu' sodep
  13. # - build from versioned source-ball, not VCS
  14. pkgname=evolution-data-server
  15. pkgver=3.44.4
  16. [[ "${CARCH}" == i686 ]] && pkgver=3.40.4
  17. pkgrel=1
  18. pkgrel+=.nonprism1
  19. pkgdesc="Centralized access to appointments and contacts"
  20. pkgdesc+=", without google, libgweather, and libgdata support"
  21. url="https://wiki.gnome.org/Apps/Evolution"
  22. arch=(x86_64)
  23. arch+=(armv7h i686)
  24. depends=(gnome-online-accounts nss krb5 libgweather-4 libical db libgdata libphonenumber
  25. libcanberra)
  26. depends=(${depends[*]/libgweather-4/})
  27. depends=(${depends[*]/libgdata/})
  28. makedepends=(intltool gperf gobject-introspection vala gtk-doc boost git cmake ninja)
  29. makedepends=( ${makedepends[*]/git/} )
  30. [[ "${CARCH}" == i686 ]] && depends+=( glib2=2.74.0 ) # Package dependency requirement 'glib-2.0 >= 2.74.0' could not be satisfied. If you want to disable GObject introspection, please use -DENABLE_INTROSPECTION=OFF
  31. provides=(libcamel-1.2.so libebackend-1.2.so libebook-1.2.so libebook-contacts-1.2.so
  32. libecal-2.0.so libedata-book-1.2.so libedata-cal-2.0.so libedataserver-1.2.so
  33. libedataserverui-1.2.so)
  34. license=(GPL)
  35. options=(debug)
  36. source=(https://gitlab.gnome.org/GNOME/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
  37. sha256sums=('9ee2f008c713102730d49ff8f56c1873ac9fa9c0210856cab094cfce5f4cfb33')
  38. [[ "${CARCH}" == i686 ]] && sha256sums=('3adaba3e7b0f72d8f65b955995cb30373bbcfe71ab3f81f6260c2c8b80bd18cb')
  39. prepare() {
  40. cd ${pkgname}-${pkgver}
  41. }
  42. build() {
  43. local privacy_options=( -DENABLE_UOA=OFF \
  44. -DENABLE_GOOGLE=OFF \
  45. -DHAVE_LIBGDATA=OFF \
  46. -DENABLE_GOOGLE_AUTH=OFF \
  47. -DENABLE_WEATHER=OFF \
  48. -DWITH_GWEATHER4=OFF )
  49. [[ "${CARCH}" == i686 ]] && privacy_options+=( -DWITH_PHONENUMBER=OFF ) # libphonenumber cannot be used. Use -DWITH_PHONENUMBER=PATH to specify the library prefix, or -DWITH_PHONENUMBER=OFF to disable it.
  50. cmake -S ${pkgname}-${pkgver} -B build -G Ninja \
  51. -DCMAKE_INSTALL_PREFIX=/usr \
  52. -DLIBEXEC_INSTALL_DIR=/usr/lib \
  53. -DSYSCONF_INSTALL_DIR=/etc \
  54. -DENABLE_INTROSPECTION=ON \
  55. -DENABLE_VALA_BINDINGS=ON \
  56. -DENABLE_GTK_DOC=ON \
  57. -DWITH_PHONENUMBER=ON \
  58. ${privacy_options[*]}
  59. cmake --build build
  60. }
  61. check() {
  62. # with networking disabled:
  63. # | The following tests FAILED:
  64. # | 56 - test-cal-component (Subprocess aborted)
  65. # with networking enabled:
  66. # | The following tests FAILED:
  67. # | 34 - test-book-client-suppress-notifications (SIGTRAP)
  68. return 0
  69. cd build
  70. ctest --output-on-failure --stop-on-failure
  71. }
  72. package() {
  73. depends+=(libicui18n.so libicuuc.so)
  74. DESTDIR="$pkgdir" cmake --install build
  75. }