PKGBUILD 2.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576
  1. # Maintainer: David P. <megver83@parabola.nu>
  2. _target=xtensa-elf
  3. pkgname=$_target-binutils
  4. pkgver=2.39
  5. pkgrel=1
  6. pkgdesc='A set of programs to assemble and manipulate binary and object files for the Xtensa (bare-metal) target'
  7. arch=(x86_64 i686 armv7h)
  8. url="https://www.gnu.org/software/binutils/"
  9. license=(GPL)
  10. depends=(zlib libelf)
  11. source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig}
  12. binutils-2.36_fixup.patch binutils-2.34_fixup.patch binutils.patch)
  13. sha512sums=('faa592dd48fc715901ad704ac96dbd34b1792c51e77c7a92a387964b0700703c74be07de45cc4751945c8c0674368c73dc17bbc563d1d2cd235b5ebd8c6e7efb'
  14. 'SKIP'
  15. 'fa1e3e1b30d625eae4e59f1396079cc3fa4d77ec4f119ad20c52db1e1ff1819989ff16dc583d7c719caeb7c0ece48d76fe7c08a85b960c7bc924fe780ffa4ac2'
  16. '4e5bbba907eec565f5c3ea00fa5a19c146ec19b1f2db38c6581f80a524475ad9b066839ca671da05c6fab9af402f2bb76e01d227e7456b3ef48c6d685605c8d1'
  17. 'e10ed358794d7aa32ac25087afd804dc4c3028c4664d7608eb86147f041561d16209afa6501bc8a19e02386674011d567640175f6b8bf89275c243dc3b3a9980')
  18. validpgpkeys=('3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
  19. prepare() {
  20. cd binutils-$pkgver
  21. sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
  22. # https://github.com/qca/open-ath9k-htc-firmware/pull/168
  23. patch -Np1 -i ../binutils-2.36_fixup.patch
  24. # https://github.com/qca/open-ath9k-htc-firmware/tree/master/local/patches
  25. patch -Np1 -i ../binutils-2.34_fixup.patch
  26. patch -Np1 -i ../binutils.patch
  27. }
  28. build() {
  29. cd binutils-$pkgver
  30. if [ "${CARCH}" != "i686" ]; then
  31. # enabling gold linker at i686 makes the install fail
  32. enable_gold='--enable-gold'
  33. fi
  34. ./configure --target=$_target \
  35. --with-sysroot=/usr/$_target \
  36. --prefix=/usr \
  37. --disable-multilib \
  38. --with-gnu-as \
  39. --with-gnu-ld \
  40. --disable-nls \
  41. --enable-ld=default \
  42. $enable_gold \
  43. --enable-plugins \
  44. --enable-deterministic-archives
  45. make
  46. }
  47. check() {
  48. cd binutils-$pkgver
  49. # unset LDFLAGS as testsuite makes assumptions about which ones are active
  50. # do not abort on errors - manually check log files
  51. make LDFLAGS="" -k check || true
  52. }
  53. package() {
  54. cd binutils-$pkgver
  55. make DESTDIR="$pkgdir" install
  56. # Remove file conflicting with host binutils and manpages for MS Windows tools
  57. rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,windres,windmc}*
  58. rm "$pkgdir"/usr/lib/bfd-plugins/libdep.so
  59. # Remove info documents that conflict with host version
  60. rm -r "$pkgdir"/usr/share/info
  61. }