PKGBUILD 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. # Maintainer (arch): Maxime Gauduin <alucryd@archlinux.org>
  2. # Contributor: Themaister <maister@archlinux.us>
  3. # Contributor: lifning <definelightning@gmail.com>
  4. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  5. # Contributor: André Silva <emulatorman@hyperbola.info>
  6. # Contributor: Nikita Epifanov <nikgreens@protonmail.com>
  7. # Contributor: bill-auger <bill-auger@programmer.net>
  8. # rationale for inclusion in [libre]:
  9. # - disable auto-updater/downloader
  10. # - build from versioned source-ball rather than VCS
  11. pkgname=retroarch
  12. _upstream_name=RetroArch
  13. pkgver=1.16.0.3
  14. pkgrel=1
  15. pkgrel+=.parabola1
  16. pkgdesc='Reference frontend for the libretro API'
  17. arch=(x86_64)
  18. arch+=(armv7h i686)
  19. url=http://www.libretro.com/
  20. license=(GPL)
  21. groups=(libretro)
  22. depends=(
  23. alsa-lib
  24. dbus
  25. ffmpeg
  26. flac
  27. fontconfig
  28. fribidi
  29. gcc-libs
  30. glibc
  31. libass.so
  32. libdrm
  33. libfreetype.so
  34. libgl
  35. libpulse
  36. libudev.so
  37. libusb
  38. libx11
  39. libxcb
  40. libxext
  41. libxinerama
  42. libxkbcommon
  43. libxrandr
  44. libxxf86vm
  45. libxv
  46. mbedtls2
  47. mesa
  48. openssl
  49. qt5-base
  50. sdl2
  51. v4l-utils
  52. wayland
  53. zlib
  54. )
  55. depends+=(libmbedcrypto.so)
  56. makedepends=(
  57. gamemode
  58. git
  59. libdecor
  60. vulkan-icd-loader
  61. wayland-protocols
  62. )
  63. optdepends=(
  64. 'gamemode: GameMode support'
  65. 'libdecor: Wayland decorations'
  66. 'libretro-overlays: Collection of overlays'
  67. 'libretro-shaders: Collection of shaders'
  68. 'python: retroarch-cg2glsl'
  69. 'retroarch-assets-ozone: Ozone menu assets'
  70. 'retroarch-assets-xmb: XMB menu assets'
  71. )
  72. backup=(etc/retroarch.cfg)
  73. source=(
  74. ${pkgname}-${pkgver}.tar.gz::https://github.com/libretro/${_upstream_name}/archive/refs/tags/v${pkgver}.tar.gz
  75. retroarch-config.patch
  76. )
  77. source+=(disable-auto-update.patch)
  78. b2sums=('e04b33585085679262da52ba37a960c1b5076628ffeaadd0beb7bceaf092f7a202677622fec5156ee61afdffbbaae050379d8038ef331475b17a7f0bbb8c50b3'
  79. '5ecbe57126c7f9b66bdf189f0af2f1cec031cb68ea85bb9609847ba9beb0e720c902cd3330d7c286901a73e6c2e272c3f04166cf9a47bb6f80097f19dde8ce3a')
  80. b2sums+=('232dd01998f119ba00082212d4a44f3be3664b1027c937e54529c0186626b0445e34e551ee3fa9982fffbada7c57c6bbe11e6e6716eea4fc4ad5488e74cabf73')
  81. prepare() {
  82. cd ${_upstream_name}-${pkgver}
  83. patch -Np1 -i ../retroarch-config.patch
  84. echo "applying disable-auto-update.patch"
  85. patch -Np1 -i ${srcdir}/disable-auto-update.patch
  86. }
  87. build() {
  88. cd ${_upstream_name}-${pkgver}
  89. export CFLAGS+=' -I/usr/include/mbedtls2'
  90. export LDFLAGS+=' -L/usr/lib/mbedtls2'
  91. ./configure \
  92. --prefix=/usr \
  93. --disable-builtinflac \
  94. --disable-builtinmbedtls \
  95. --disable-builtinzlib \
  96. --disable-cg \
  97. --disable-jack \
  98. --disable-oss \
  99. --disable-sdl \
  100. --enable-dbus
  101. make
  102. make -C libretro-common/audio/dsp_filters
  103. make -C gfx/video_filters
  104. }
  105. package() {
  106. cd ${_upstream_name}-${pkgver}
  107. make DESTDIR="${pkgdir}" install
  108. install -Dm 644 libretro-common/audio/dsp_filters/*.{dsp,so} -t "${pkgdir}"/usr/lib/retroarch/filters/audio/
  109. install -Dm 644 gfx/video_filters/*.{filt,so} -t "${pkgdir}"/usr/lib/retroarch/filters/video/
  110. }